Bug 495301 - PulseAudio segfaults within five minutes of logging in
PulseAudio segfaults within five minutes of logging in
Status: CLOSED DUPLICATE of bug 472339
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-11 08:41 EDT by Jared Smith
Modified: 2009-04-11 22:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-11 22:18:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jared Smith 2009-04-11 08:41:09 EDT
Description of problem:

I'm running rawhide very close to what's in Snapshot 1, and PulseAudio is now segfaulting within about five minutes or less of when I log in.  Once that happens, I hear no sound, and programs like pavucontrol cannot connect to the sound server.

The problem may very well be with ALSA or with the Intel sound driver, so feel free to reassign this but to one of those components if applicable.

Version-Release number of selected component (if applicable):

[jsmith@localhost ~]$ rpm -q pulseaudio alsa* kernel
pulseaudio-0.9.15-9.test8.fc11.i586
package alsa* is not installed
kernel-2.6.29.1-54.fc11.i586
alsa-lib-1.0.19-3.fc11.i586
alsa-plugins-pulseaudio-1.0.18-3.fc11.i586
alsa-utils-1.0.19-4.fc11.i586


How reproducible:

Always

Steps to Reproduce:
1. Log in (Probably isn't related, but the login sound is *very* broken up, and sounds awful)
2. Play sounds for a couple of minutes
3. Notice that pulseaudio is no longer running
4. Restart pulseaudio from the command-line
5. Watch it segfault
  
Actual results:

No audio after a couple of minutes

Expected results:

Audio playback should continue

Additional info:

Hardware information available at http://smolts.org/client/show/?uuid=pub_84c14bf2-1461-4cf8-afa7-f1afd4c0e177

When I restart pulseaudio from the command line, I almost immediately get the following output:

[jsmith@localhost ~]$ pulseaudio 
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
N: alsa-sink.c: Device hw:1 is modem, refusing further initialization.
N: alsa-source.c: Device hw:1 is modem, refusing further initialization.
N: alsa-source.c: Increasing minimal latency to 1.00 ms
N: alsa-source.c: Increasing minimal latency to 2.00 ms
E: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294902064 bytes (24347517 ms).
E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
E: alsa-util.c: snd_pcm_dump():
E: alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0
E: alsa-util.c: Its setup is:
E: alsa-util.c:   stream       : CAPTURE
E: alsa-util.c:   access       : MMAP_INTERLEAVED
E: alsa-util.c:   format       : S16_LE
E: alsa-util.c:   subformat    : STD
E: alsa-util.c:   channels     : 2
E: alsa-util.c:   rate         : 44100
E: alsa-util.c:   exact rate   : 44100 (44100/1)
E: alsa-util.c:   msbits       : 16
E: alsa-util.c:   buffer_size  : 16384
E: alsa-util.c:   period_size  : 16384
E: alsa-util.c:   period_time  : 371519
E: alsa-util.c:   tstamp_mode  : ENABLE
E: alsa-util.c:   period_step  : 1
E: alsa-util.c:   avail_min    : 16384
E: alsa-util.c:   period_event : 0
E: alsa-util.c:   start_threshold  : -1
E: alsa-util.c:   stop_threshold   : 1073741824
E: alsa-util.c:   silence_threshold: 0
E: alsa-util.c:   silence_size : 0
E: alsa-util.c:   boundary     : 1073741824
N: alsa-source.c: Increasing minimal latency to 4.00 ms
N: alsa-source.c: Increasing minimal latency to 8.00 ms
N: alsa-source.c: Increasing minimal latency to 16.00 ms
N: alsa-source.c: Increasing minimal latency to 26.00 ms
N: alsa-source.c: Increasing wakeup watermark to 15.99 ms
N: alsa-source.c: Increasing minimal latency to 36.00 ms
N: alsa-source.c: Increasing wakeup watermark to 25.99 ms
N: alsa-source.c: Increasing minimal latency to 46.00 ms
N: alsa-source.c: Increasing wakeup watermark to 35.99 ms
N: alsa-source.c: Increasing minimal latency to 56.00 ms
N: alsa-source.c: Increasing wakeup watermark to 45.99 ms
E: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: -710360 bytes (-4026 ms).
E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
E: alsa-util.c: snd_pcm_dump():
E: alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0
E: alsa-util.c: Its setup is:
E: alsa-util.c:   stream       : CAPTURE
E: alsa-util.c:   access       : MMAP_INTERLEAVED
E: alsa-util.c:   format       : S16_LE
E: alsa-util.c:   subformat    : STD
E: alsa-util.c:   channels     : 2
E: alsa-util.c:   rate         : 44100
E: alsa-util.c:   exact rate   : 44100 (44100/1)
E: alsa-util.c:   msbits       : 16
E: alsa-util.c:   buffer_size  : 16384
E: alsa-util.c:   period_size  : 16384
E: alsa-util.c:   period_time  : 371519
E: alsa-util.c:   tstamp_mode  : ENABLE
E: alsa-util.c:   period_step  : 1
E: alsa-util.c:   avail_min    : 16384
E: alsa-util.c:   period_event : 0
E: alsa-util.c:   start_threshold  : -1
E: alsa-util.c:   stop_threshold   : 1073741824
E: alsa-util.c:   silence_threshold: 0
E: alsa-util.c:   silence_size : 0
E: alsa-util.c:   boundary     : 1073741824
E: rtpoll.c: Assertion 'usec <= ((pa_usec_t) 1000000ULL)*60ULL*60ULL' failed at pulsecore/rtpoll.c:548, function pa_rtpoll_set_timer_relative(). Aborting.
Aborted
Comment 1 Lennart Poettering 2009-04-11 22:18:13 EDT
If you mean 'Assertion failed' when you say 'segfault' then this is a duplicate of bug 472339

*** This bug has been marked as a duplicate of bug 472339 ***

Note You need to log in before you can comment on or make changes to this bug.