Bug 495303 - yum localinstall fails if working directory contains letters with an accent
yum localinstall fails if working directory contains letters with an accent
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-11 10:22 EDT by openfred
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 18:57:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description openfred 2009-04-11 10:22:44 EDT
Description of problem:

When I Try to install a rpm package using yum localinstall, if the directory contains letters with an accent, the installation fails.

Fails (Accent in the word Téléchargement):
[root@tosh ~]# yum localinstall /home/fred/Téléchargement/openproj-1.4-2.noarch.rpm 

Succeeds:
[root@tosh ~]# yum localinstall /home/fred/Fedora/openproj-1.4-2.noarch.rpm

Version-Release number of selected component (if applicable):
yum 3.2.21-2.fc10 (uptodate)

How reproducible:

Simply download an rpm file to install, and launch yum localinstall (with the rpm package in a path containing accent)

Steps to Reproduce:
1.
Install Fedora using a language containing accents (e.g. French)
2.
In the home directory, Downloads has been renamed Téléchargement, put the rpm file here
3.
launch yum localinstall:
# yum localinstall /home/fred/Téléchargement/package.rpm
  
Actual results:
[root@tosh ~]# yum localinstall /home/fred/Téléchargement/openproj-1.4-2.noarch.rpm 
Modules complémentaires chargés : fastestmirror, protectbase, refresh-packagekit
Configuration du processus de paquetages locaux
Loading mirror speeds from cached hostfile
 * fedora: fedora.univ-nantes.fr
 * updates: fedora.univ-nantes.fr
0 packages excluded due to repository protections
Résolution des dépendances
--> Lancement de la transaction de test
---> Paquetage openproj.noarch 0:1.4-2 marqué pour être mis à jour 
--> Résolution des dépendances terminée

Dépendances résolues
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 181, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 356, in doTransaction
    self.listTransaction())
  File "/usr/share/yum-cli/output.py", line 954, in listTransaction
    msg = self.fmtColumns(columns, u" ", u"\n")
  File "/usr/share/yum-cli/output.py", line 460, in fmtColumns
    return msg % tuple(data)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 12: ordinal not in range(128)
[root@tosh ~]# 


Expected results:
Installé:
  openproj.noarch 0:1.4-2                                                                                                                                     

Terminé !

Means: Installed, Terminated :-)

Additional info:

It's the first time my homedir is so "translated"...
First time I encounter that bug that might be there for a while
Comment 1 seth vidal 2009-04-13 12:36:05 EDT
Two questions:

1. I can't replicate this on 3.2.22 from rawhide
2. What LANG/LOCALE are you running this command in?

thanks
Comment 2 seth vidal 2009-04-13 12:38:28 EDT
Hmm #1 should be: I can't replicate this on 3.2.22, can you?


Thanks
Comment 3 seth vidal 2009-04-13 12:39:11 EDT
Ah ha. I can replicate it now. I wasn't performing it exactly like you did.
Comment 4 openfred 2009-04-13 17:30:20 EDT
Hello Seth,

Thanks for your interest about this bug. I rated it as "low", but it may give a bad opinion about yum for people not "native" english.
Glad you've been able to reproduce the bug.

To reply to your question: 
yum-3.2.21-2.fc10.noarch (F10 x86_64, up-to-date)

[root@tosh ~]# echo $LANG
fr_FR.UTF-8
[root@tosh ~]# echo $LOCALE

[root@tosh ~]# cat /etc/sysconfig/i18n 
LANG="fr_FR.UTF-8"
SYSFONT="latarcyrheb-sun16"

LOCALE environment variable is not set on my PC.

Hope this will help

Cheers
Fred
Comment 5 seth vidal 2009-04-13 18:57:57 EDT
James Antill has checked in a fix for this problem here:

http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=ec84b2d2123937288d10975cbee74785aa1e5364

it'll be corrected in rawhide version of yum soon.

Note You need to log in before you can comment on or make changes to this bug.