Bug 495317 - KDE font width not correct, cursor shown at wrong position
KDE font width not correct, cursor shown at wrong position
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-11 15:09 EDT by Raman Gupta
Modified: 2009-05-31 13:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-31 13:02:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raman Gupta 2009-04-11 15:09:49 EDT
Description of problem:

When writing text into dialog boxes, such as the kicker search dialog, KDE does not appear to know the correct display width of some characters, resulting in strange display artifacts, such as the cursor showing in the wrong place.

I have attached pics where the cursor shows somewhere in the middle of the text rather than at the end of the line.

Version-Release number of selected component (if applicable):

# rpm -q --info kdebase | head -2
Name        : kdebase                      Relocations: (not relocatable)
Version     : 4.2.1                             Vendor: Fedora Project
Release     : 2.fc10                        Build Date: Wed 04 Mar 2009 04:12:08 PM EST


How reproducible:

Always.


Steps to Reproduce:
On my machine I can reproduce via using the Liberation Sans Regular font, at size 8.

1. Open the kicker menu.
2. Type a's into the search box and watch the position of the cursor.

  
Actual results:

Cursor position is not at the end of the text.


Expected results:

Cursor position is at the end of the text.


Additional info:

I cannot reproduce the problem using Liberation Sans Regular, size 9.

Force fonts DPI is disabled.

Anti-aliasing is enabled.

Sub-pixel rendering is enabled (RGB).

Hinting style is Medium.

I am using freetype-freeworld 2.3.7.2 from Livna.

I have attached two pics:

Liberation Sans Regular, size 9, no problem:
http://img152.imageshack.us/img152/5628/fontdialogwithasize9.png

Liberation Sans Regular, size 8, showing problem:
http://img208.imageshack.us/img208/7547/fontdialogwithasize8.png
(the cursor is at the end of the text, but is not showing there)

This also happens in other dialog boxes, such as krunner and others.
Comment 1 Steven M. Parrish 2009-05-30 22:06:48 EDT
Thank you for the report.  This is an issue that needs to be addressed by the
upstream developers.  Please report this upstream at http://bugs.kde.org  and
add the upstream information to this report.
Comment 2 Raman Gupta 2009-05-31 13:02:12 EDT
I cannot reproduce with kde 4.2.3.

Note You need to log in before you can comment on or make changes to this bug.