Bug 49532 - Oracle 9i can not be installed on RedHat linux 7.1 Box
Summary: Oracle 9i can not be installed on RedHat linux 7.1 Box
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-20 14:25 UTC by Need Real Name
Modified: 2016-11-24 14:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 15:19:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-07-20 14:25:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [de] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
The new Oracle 9i Database can not be installed on RedHat 7.1 (I think 7.0
is also affected). During Installation the Installer tries to relink the
Database Kernel (or at least libclntsh). The Workaround mentioned in RedHat
Release Notes for Oracle 8i does not work because 9i needs glibc 2.2.
Sorry, I have no linker Output at the moment, but there are unresolved
Symbols which can not be found by the linker. These Symbols all start with
_ or __



How reproducible:
Always

Steps to Reproduce:
1.Try to install Oracle 9i
2.Look at the installation logs (oraInventory/logs/installActions.log)
3.
	

Actual Results:  Oracle does not work ;-(

Expected Results:  Oracle should work. 

Additional info:

Comment 1 Need Real Name 2001-07-20 14:29:56 UTC
I just forget: 

The script, wich tries to link is located in $ORACLE_HOME/bin/genclntsh. I can
mail this to you if you like.

Comment 2 Jakub Jelinek 2001-07-22 18:56:18 UTC
What exactly does not work? Does it link or not?
The workaround mentioned in release notes is obviously meant
for Oracle 8i, not 9i.
I believe you should report this to Oracle, there is not much
we can do about their bugs, especially as they are closed-source.

Comment 3 Need Real Name 2001-07-23 23:11:07 UTC
Hello,

as I wrote it does not link because the linker can not find symbols ob GLIBC. 
I think these symbols are for internal use only, but Oracle uses them. So a 
totally unstripped GLIBC, or anything like that would help


Note You need to log in before you can comment on or make changes to this bug.