Bug 495324 - New version of pyparsing is available (1.5.1)
New version of pyparsing is available (1.5.1)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pyparsing (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Terje Røsten
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 495322 645277
  Show dependency treegraph
 
Reported: 2009-04-11 18:47 EDT by Silas Sewell
Modified: 2010-11-08 17:43 EST (History)
4 users (show)

See Also:
Fixed In Version: pyparsing-1.5.5-1.fc14
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-08 17:43:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Silas Sewell 2009-04-11 18:47:57 EDT
Version 1.5.1 of pyparsing is available.

http://sourceforge.net/project/showfiles.php?group_id=97203
Comment 1 John Poelstra 2009-06-08 15:29:10 EDT
Adding 'FutureFeature' keyword to avoid rawhide rebase.
Comment 2 Thomas Spura 2010-06-19 13:31:26 EDT
When updating, please split out the doc into a subpackage, currently the docs need 93% of the whole package!!

Splitting the docs into a subpackage is expecially usefull for people with a low internet connection...

Thanks!
Comment 3 Terje Røsten 2010-10-21 04:16:58 EDT
Anything stopping the update? 

I need pyparsing 1.5.5 for puddletag (bug #645277 ).

1.5.5 has support for python3 which should be included too. 
Updated package in F14 would be nice too.
Comment 4 Thomas Spura 2010-10-21 04:44:29 EDT
(In reply to comment #3)
> Anything stopping the update? 
> 
> I need pyparsing 1.5.5 for puddletag (bug #645277 ).
> 
> 1.5.5 has support for python3 which should be included too. 
> Updated package in F14 would be nice too.

How about applying for co-maintainer? ;)
Comment 5 Terje Røsten 2010-10-21 14:19:10 EDT
I done some work on the package:

- 1.5.5
- use buildroot macro
- fix wrong file end of line encoding
- convert files to utf-8
- doc subpackage
- python3 subpackage
- rpmlint clean

My work is available here:

spec: http://terjeros.fedorapeople.org/pyparsing/pyparsing.spec
srpm: http://terjeros.fedorapeople.org/pyparsing/pyparsing-1.5.5-1.fc13.src.rpm
koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=2547273


Would be nice with some feedback from Jose.
Comment 6 José Matos 2010-10-21 14:34:30 EDT
I was convinced (wrongly as it can be seen) that I had updated pyparsing.
At the moment I am quite busy so could you please drive this release?

Please go ahead for rawhide and F-14.
Comment 7 José Matos 2010-10-21 14:36:35 EDT
FWIW your changes to the spec file are sane. :-)
Comment 8 Terje Røsten 2010-10-25 09:05:14 EDT
Update coming soon.
Comment 9 Fedora Update System 2010-10-25 09:09:14 EDT
pyparsing-1.5.5-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pyparsing-1.5.5-1.fc14
Comment 10 Fedora Update System 2010-10-28 01:50:01 EDT
pyparsing-1.5.5-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pyparsing'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/pyparsing-1.5.5-1.fc14
Comment 11 Fedora Update System 2010-11-08 17:43:12 EST
pyparsing-1.5.5-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.