Bug 495331 - NetworkManager will not connect to wireless AP even though I can manually
NetworkManager will not connect to wireless AP even though I can manually
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 00:01 EDT by Walter Francis
Modified: 2010-06-10 01:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 01:17:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages logs of the failing attempts by Network Manager (9.80 KB, text/plain)
2009-04-12 00:01 EDT, Walter Francis
no flags Details
WPA Supplicant log with -dddt as described (61.30 KB, text/plain)
2009-04-15 22:40 EDT, Walter Francis
no flags Details

  None (edit)
Description Walter Francis 2009-04-12 00:01:15 EDT
Created attachment 339208 [details]
/var/log/messages logs of the failing attempts by Network Manager

Description of problem:

My older test laptop, a Sony SRX87 with "Orinoco" card in it, has always worked fine wireless.  I've never been able to get WPA on it due to its old wireless card, so I have a secondary AP set up here which is MAC filtered for this machines wireless card.

Since installing F11 I have not been able to get NetworkManager to connect to this AP any longer, even though I've tried disabling MAC Filtering (just in case), tried the WPA router here (supposedly the FW that's called out to be used now from dmesg supports it?), etc.

What does work is stopping NetworkManager ; iwconfig eth1 essid ssid ; dhclient eth1, and it works every time.

I have loaded the following firmware into /lib/firmware, as I could not find it in Fedora and the orinoco module was calling it out in dmesg, I found what appeared to be appropriate.  It's name is agere_sta_fw.bin

Version-Release number of selected component (if applicable):

NetworkManager-0.7.0.100-2.git20090408.fc11.i586

How reproducible:

100%

Steps to Reproduce:
Not sure how to say how to reproduce it, I reproduce it 100% of the time.  I'm willing to try any suggestions to find workarounds to make NM work to get it fixed.

Other Information:

Smolt profile:
http://www.smolts.org/client/show/pub_3baef49f-9284-4d50-8ff7-e62177614371

Attaching relevant /var/log/messages logs after a fresh boot, during which I try to connect, let it fail a few times, then service NetworkManager stop and proceed to iwconfig/dhclient and connect.
Comment 1 Walter Francis 2009-04-12 00:05:17 EDT
Doesn't look like smolt really picked up much about the wireless card that I can see, I thought it would have.

Not sure what info to provide, here's dmesg output about it:

pcmcia_socket pcmcia_socket1: pccard: PCMCIA card inserted into slot 1
pcmcia_socket pcmcia_socket1: cs: memory probe 0xf4100000-0xf41fffff: excluding 0xf4100000-0xf410ffff
pcmcia 1.0: pcmcia: registering new device pcmcia1.0
orinoco 0.15 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
orinoco_cs 0.15 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
eth1 (orinoco_cs): not using net_device_ops yet
eth1: Hardware identity 0005:0002:0001:0002
eth1: Station identity  001f:0001:0006:0010
eth1: Firmware determined as Lucent/Agere 6.16
orinoco_cs 1.0: firmware: requesting agere_sta_fw.bin
eth1: Attempting to download firmware agere_sta_fw.bin
hermes_dld: AUX enable returned 0
hermes_dld: AUX disable returned 0
Comment 2 Dan Williams 2009-04-14 22:42:11 EDT
Orinoco can actually do WPA now as of 2.6.27, but you'll need to get v9 firmware from somewhere.  Like:

http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=tree

In any case, can you add "-dddt" to the end of the Exec= line in /usr/share/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service, then 'killall -TERM wpa_supplicant' (as root), then try to reconnect?  When it fails, grab /var/log/wpa_supplicant.log and attach it to this bug.  That will shed a lot more light on what's going wrong.

Since the WE-18 support in orinoco is so new, I'm not really surprised that it could be failing for WEP or open networks.
Comment 3 Walter Francis 2009-04-15 22:40:09 EDT
ahem, I wish you'd reminded me that downloading firmware from GIT screws up the encoding ;-)  recode utf8..iso8859-1 agere_sta_fw.bin

And to do it, I had to acpi=off because the laptop would bomb, couldn't even get into init 1.  orinico didn't like loading corrupted firmware I guess.

Anywho, I'm attaching the logs.  For giggles I've tried my unencrypted AP and my WPA AP.  Neither would connect.
Comment 4 Walter Francis 2009-04-15 22:40:56 EDT
Created attachment 339776 [details]
WPA Supplicant log with -dddt as described
Comment 5 Niels Haase 2009-05-07 15:05:33 EDT
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Bug Zapper 2009-06-09 09:40:40 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Scott Dunlop 2009-10-01 17:37:05 EDT
I am experiencing the same issue with my system. The stranger part is that the older kernel (2.6.29.4-167) works, but the newest kernel (2.6.30.8-64) does not. I have already tried re-installing all associated apps and firmware but I have yet to determine the issue.
Comment 8 Dan Williams 2009-11-10 20:21:06 EST
(In reply to comment #7)
> I am experiencing the same issue with my system. The stranger part is that the
> older kernel (2.6.29.4-167) works, but the newest kernel (2.6.30.8-64) does
> not. I have already tried re-installing all associated apps and firmware but I
> have yet to determine the issue.  

Scott, do you have an orinoco card?  If not, could you file another bug report your specific issue?

Walter: does this still happen with latest F11 kernel updates (2.6.30.9-96.fc11) ?
Comment 9 Bug Zapper 2010-04-27 09:38:13 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Dan Williams 2010-06-10 01:17:53 EDT
CLosing due to lack of response.  Walter, if this still happens with a recent kernel (latest is 2.6.30.10-105) please re-open.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.