Bug 495341 - gthumb import tool does not work for autodetected camera.
gthumb import tool does not work for autodetected camera.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 04:04 EDT by Russell Strong
Modified: 2015-03-03 17:40 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:48:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Strong 2009-04-12 04:04:07 EDT
Description of problem:

I connected my canon 350D camera (ptp).  A dialog appeared giving me some options for actions to take.  I chose to open with the gthumb import tool.  After this nothing happened until my camera got bored with it and powered itself down.

I then noticed that gphoto2 and gvfs-gphoto2 were not installed.  I suspect they are required so I installed them and tried again.  Same result, nothing.

I repeated this several times, same thing each time.

I then tried selecting gthumb instead of the import tool.  This worked well.

After a bit more digging, I found that the camera was mounted under ~me/.gvfs even after selecting the import tool.  I suspect this is the real issue.  Should it be unmounted prior to trying to launch the import tool?
Comment 1 Matthias Clasen 2009-04-12 18:10:10 EDT
If you look at /usr/bin/gthumb-importer, that (unmounting) is exactly what the script is trying to do before starting gthumb. It would be good to find out why that is failing for you.
Comment 2 Bug Zapper 2009-06-09 09:40:59 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Ralf Corsepius 2009-12-20 12:23:40 EST
This had been working for me with F11, but I am now facing the
same issue on F12, now.
Comment 4 Bug Zapper 2010-04-27 09:38:25 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2010-06-28 07:48:29 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.