Bug 495342 - driconf does not detect direct rendering capable display
driconf does not detect direct rendering capable display
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 498565 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 04:21 EDT by Eddie Lania
Modified: 2009-05-08 11:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 11:29:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eddie Lania 2009-04-12 04:21:43 EDT
Description of problem:

glxinfo |grep -i direct
direct rendering: Yes

driconf
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Screen "0" is not direct rendering capable.
/usr/lib/python2.6/site-packages/driconf_complexui.py:213: DeprecationWarning: use gtk.ComboBoxEntry
  self.screenCombo = gtk.Combo()
/usr/lib/python2.6/site-packages/driconf_complexui.py:224: DeprecationWarning: use gtk.ComboBoxEntry
  self.driverCombo = gtk.Combo()
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Screen "0" is not direct rendering capable.



Version-Release number of selected component (if applicable):
driconf-0.9.1-12.fc11.noarch


How reproducible: always


Steps to Reproduce:
1.install driconf
2.start driconf in terminal
3.observe messages
  
Actual results:
Screen "0" is not direct rendering capable.

Expected results:
Dri should detect direct rendering capable device.

Additional info:
Comment 1 Kevin Fenzi 2009-04-12 14:42:04 EDT
driconf is just calling the '/usr/bin/xdriinfo' command from glx-utils, which is built from the mesa package. 

The fix likely needs to be there.
Comment 2 Eddie Lania 2009-04-12 15:14:16 EDT
So it seems:

xdriinfo 
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Screen 0: not direct rendering capable.

Happy Easter.
Comment 3 Adam Jackson 2009-04-15 11:29:33 EDT
Fixed in 7.5-0.10, to be included in F11 gold.
Comment 4 Adam Jackson 2009-05-07 17:24:24 EDT
*** Bug 498565 has been marked as a duplicate of this bug. ***
Comment 5 Eddie Lania 2009-05-08 11:04:40 EDT
What might "F11 gold" be?
Comment 6 Kevin Fenzi 2009-05-08 11:45:17 EDT
The final real release of Fedora 11 (after alpha, beta, snapshots, preview, rc's). 

http://en.wikipedia.org/wiki/Software_release_life_cycle

Note You need to log in before you can comment on or make changes to this bug.