Bug 495347 - Firefox seems to mangle the downloaded file
Firefox seems to mangle the downloaded file
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-04-12 05:44 EDT by Lubomir Rintel
Modified: 2009-04-30 00:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 00:55:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2009-04-12 05:44:27 EDT
Description of problem:

Try to download the resource at the following URL:
https://bugzilla.redhat.com/attachment.cgi?id=339162

When downloading with Firefox, the file is corrupted, has the following md5sum:
d44ebb9f0b00c27c9ee35e0bf4f395eb  anaconda.bug.495290.tar.gz

Wget and Links download the file correctly:
6642bd4fe6442057e7d0178639625d82  anaconda.bug.495290.tar.gz

Version-Release number of selected component (if applicable):

firefox-3.1-0.11.beta3.fc11.i586
xulrunner-1.9.1-0.11.beta3.fc11.i586

How reproducible:

Always
Comment 1 Matěj Cepl 2009-04-29 18:40:03 EDT
Weird, cannot reproduce here. I get two identical files:

[matej@viklef tmp]$ ls -l anaconda.bug.495290*
-rw-rw-r--. 1 matej matej 181517 30. dub 00.36 anaconda.bug.495290-firefox.tar.gz
-rw-rw-r--. 1 matej matej 181517 30. dub 00.37 anaconda.bug.495290.tar.gz
[matej@viklef tmp]$ md5sum anaconda.bug.495290*
6642bd4fe6442057e7d0178639625d82  anaconda.bug.495290-firefox.tar.gz
6642bd4fe6442057e7d0178639625d82  anaconda.bug.495290.tar.gz
[matej@viklef tmp]$ gzip --test --verbose anaconda.bug.495290*
anaconda.bug.495290-firefox.tar.gz:	 OK
anaconda.bug.495290.tar.gz:	 OK
[matej@viklef tmp]$ 

Is there anything non-standard with your configuration? Plugins (can you reproduce it with -safe-mode)? Some network configuration (e.g., proxies)?
Comment 2 Lubomir Rintel 2009-04-30 00:55:57 EDT
I did not manage to reproduce this today, with the following revisions:

firefox-3.1-0.11.beta3.fc11.i586
xulrunner-1.9.1-0.11.beta3.fc11.i586

Which seem to be the same versions I reported against. I conclude this could have been a server side problem. I've tried this multiple times with the same faulty results before and marek even reproduced this on ancient fc8 firefox as well.

Sorry for bothering you; closing.

Note You need to log in before you can comment on or make changes to this bug.