This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 495362 - [PATCH] Improve error reporting a bit
[PATCH] Improve error reporting a bit
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: file-roller (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-04-12 06:41 EDT by Lubomir Rintel
Modified: 2009-04-12 20:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-12 20:26:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Don't show a null error message (1.12 KB, text/plain)
2009-04-12 06:41 EDT, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2009-04-12 06:41:07 EDT
Created attachment 339228 [details]
Don't show a null error message

Description of problem:

Got a following error message:

An error occurred while loading the archive.
(null)

Though it was rather clear from the command output that the archive is corrupted, a casual user would not appreciate seeing "(null)" in an error message.

Please apply the patch that instructs the user to inspect the command output to find out the cause of the fail.

Version-Release number of selected component (if applicable):

file-roller-2.26.0-1.fc11.i586
Comment 1 Matthias Clasen 2009-04-12 18:27:37 EDT
Thats a fine patch to send upstream. 
But since it adds new translated strings, it will give a less than perfect experience - I'd say that it is only marginally better for a Chinese user to see some English sentence instead of "null". 

How about this instead ?

--- fr-window.c.error-msg	2009-04-12 18:25:09.421337520 -0400
+++ fr-window.c	2009-04-12 18:26:45.327336763 -0400
@@ -2961,7 +2961,7 @@
 						0,
 						output,
 						msg,
-						"%s", details);
+						details ? "%s" : NULL, details);
 		fr_window_show_error_dialog (window, dialog, dialog_parent);
 
 		return FALSE;
Comment 2 Lubomir Rintel 2009-04-12 19:05:01 EDT
(In reply to comment #1)
> Thats a fine patch to send upstream. 
> But since it adds new translated strings, it will give a less than perfect
> experience - I'd say that it is only marginally better for a Chinese user to
> see some English sentence instead of "null". 

Well, it will propagate into .po files and probably get translated once. Sorry for not providing a Chinese translation ;)

> How about this instead ?
[...]

Thought about that. Doesn't look well in that dialog, there's an empty space there.
Comment 3 Matthias Clasen 2009-04-12 20:26:28 EDT
Filed upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=578800

Note You need to log in before you can comment on or make changes to this bug.