Bug 495383 - postfix update erases /etc/rc.d/rc?.d/ startup scripts
postfix update erases /etc/rc.d/rc?.d/ startup scripts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 11:39 EDT by Keith Roberts
Modified: 2009-04-15 06:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 06:59:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Roberts 2009-04-12 11:39:03 EDT
Description of problem:

When I updated my F10 installation on my laptop, the postfix update erased the /etc/rc.d/rc.?d/ scripts, and postfix did not start after the package update.

I did:

root init.d]# chkconfig --list postfix
service postfix supports chkconfig, but is not referenced in any runlevel (run 'chkconfig --add postfix')

Expected results:

I expect the rc?.d scripts to be left alone after the update, and the run-levels not to be altered.

Additional info:

I had to do:

# chkconfig --add postfix
# chkconfig --level 2345 postfix on

to enable postfix to start again after the update.
Comment 1 Miroslav Lichvar 2009-04-12 16:11:09 EDT
What does "alternatives --display mta" say? Any chance the update installed another mta?
Comment 2 Keith Roberts 2009-04-13 03:51:07 EDT
# alternatives --display mta:

mta - status is manual.
 link currently points to /usr/sbin/sendmail.sendmail
/usr/sbin/sendmail.sendmail - priority 90
 slave mta-pam: /etc/pam.d/smtp.sendmail
 slave mta-mailq: /usr/bin/mailq.sendmail
 slave mta-newaliases: /usr/bin/newaliases.sendmail
 slave mta-rmail: /usr/bin/rmail.sendmail
 slave mta-sendmail: /usr/lib/sendmail.sendmail
 slave mta-mailqman: /usr/share/man/man1/mailq.sendmail.1.gz
 slave mta-newaliasesman: /usr/share/man/man1/newaliases.sendmail.1.gz
 slave mta-aliasesman: /usr/share/man/man5/aliases.sendmail.5.gz
 slave mta-sendmailman: /usr/share/man/man8/sendmail.sendmail.8.gz
/usr/sbin/sendmail.postfix - priority 30
 slave mta-pam: /etc/pam.d/smtp.postfix
 slave mta-mailq: /usr/bin/mailq.postfix
 slave mta-newaliases: /usr/bin/newaliases.postfix
 slave mta-rmail: /usr/bin/rmail.postfix
 slave mta-sendmail: /usr/lib/sendmail.postfix
 slave mta-mailqman: /usr/share/man/man1/mailq.postfix.1.gz
 slave mta-newaliasesman: /usr/share/man/man1/newaliases.postfix.1.gz
 slave mta-aliasesman: /usr/share/man/man5/aliases.postfix.5.gz
 slave mta-sendmailman: /usr/share/man/man1/sendmail.postfix.1.gz
Current `best' version is /usr/sbin/sendmail.sendmail.


Looks like you're right there Miroslav :)

# yum info sendmail:

Loaded plugins: refresh-packagekit
Installed Packages
Name       : sendmail
Arch       : i386
Version    : 8.14.3
Release    : 3.fc10
Size       : 1.5 M
Repo       : installed
Summary    : A widely used Mail Transport Agent (MTA)
URL        : http://www.sendmail.org/
License    : Sendmail
Description: The Sendmail program is a very widely used Mail Transport Agent
           : (MTA). MTAs send mail from one machine to another. Sendmail is not
           : a client program, which you use to read your email. Sendmail is a
           : behind-the-scenes program which actually moves your email over
           : networks or the Internet to where you want it to go.
           :
           : If you ever need to reconfigure Sendmail, you will also need to
           : have the sendmail-cf package installed. If you need documentation
           : on Sendmail, you can install the sendmail-doc package.


# yum info postfix:

Loaded plugins: refresh-packagekit
Installed Packages
Name       : postfix
Arch       : i386
Epoch      : 2
Version    : 2.5.6
Release    : 1.fc10
Size       : 9.3 M
Repo       : installed
Summary    : Postfix Mail Transport Agent
URL        : http://www.postfix.org
License    : IBM
Description: Postfix is a Mail Transport Agent (MTA), supporting LDAP, SMTP AUTH
           : (SASL), TLS


The thing is I purposely removed sendmail and replaced it with postfix during the initial installation. I never use sendmail and prefer postfix in it's place.

Maybe sendmail got pulled in as dependency during the package update process?

I could try removing sendmail and running the update command and then see what package may pull sendmail in as a dependency?
Comment 3 Keith Roberts 2009-04-13 03:56:42 EDT
Removing sendmail does not remove any other packages that depend on it, which is correct IMHO.

# yum remove sendmail

Loaded plugins: refresh-packagekit
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package sendmail.i386 0:8.14.3-3.fc10 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================
 Package         Arch        Version                 Repository        Size
============================================================================
Removing:
 sendmail        i386        8.14.3-3.fc10           installed        1.5 M

Transaction Summary
============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       1 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : sendmail                                             1/1

Removed:
  sendmail.i386 0:8.14.3-3.fc10

Complete!
Comment 4 Keith Roberts 2009-04-13 04:00:18 EDT
After removing sendmail:

# yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
No packages marked for update.
Comment 5 Miroslav Lichvar 2009-04-14 05:11:00 EDT
Can you check the logs in /var/log/messages* to see if it was installed in the update and which version of yum was used?

It might be a duplicate of bug #472756.
Comment 6 Keith Roberts 2009-04-14 17:48:01 EDT
/var/log/yum.log:

Apr 11 06:23:16 Updated: PackageKit-yum-0.3.14-1.fc10.i386
Apr 11 06:23:17 Updated: PackageKit-yum-plugin-0.3.14-1.fc10.i386
Apr 11 06:23:27 Updated: PackageKit-0.3.14-1.fc10.i386
Apr 11 06:23:56 Updated: gnome-packagekit-0.3.14-1.fc10.i386
...
Apr 11 06:40:12 Updated: yum-3.2.21-2.fc10.noarch
Apr 11 06:40:13 Updated: yum-utils-1.1.19-1.fc10.noarch
...
Apr 11 06:57:34 Updated: sendmail-8.14.3-3.fc10.i386


/root/install.log:
Installing sendmail-8.14.3-1.fc10.i386

It looks like I installed postfix and forgot to erase sendmail :(

I must have just turned sendmail off with chkconfig --level 0123456 sendmail off.

Even so, that should not allow a sendmail update to remove the /etc/rc.d/rc?.d/ startup scripts for postfix should it?

WRT bug #472756, I'm installing fetchmail as well as postfix.
Comment 7 Miroslav Lichvar 2009-04-15 03:37:14 EDT
I think this works as intended. The links in /etc/rc.d/rc?.d/ are managed by alternatives(8) so there is only the selected service or the one with the highest priority if left in automatic mode (sendmail has higher priority than postfix).
Comment 8 Keith Roberts 2009-04-15 06:32:47 EDT
OK. I seem to remember a time when installing postfix would remove sendmail, so you only had one mta installed at a time?
Comment 9 Miroslav Lichvar 2009-04-15 06:59:59 EDT
sendmail and postfix changelogs show the alternatives system is used since 2002. They probably conflicted before that.

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.