Bug 495410 - Please keep up with upstream latest stable release
Please keep up with upstream latest stable release
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-ZendFramework (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kahl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 16:37 EDT by Sudheer Satyanarayana
Modified: 2009-08-04 20:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.8.4-2.PL1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-04 20:36:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sudheer Satyanarayana 2009-04-12 16:37:17 EDT
Description of problem:
Current version of ZF in Fedora repo is 1.7.2. The latest stable version upstream is  1.7.8  

Version-Release number of selected component (if applicable):
1.7.2


Additional info:
Let me know if you require an additional hand maintaining the package.
Comment 1 Alexander Kahl 2009-04-14 03:57:40 EDT
Hi Sudheer,

1.7.7 has been in updates-testing for almost a month; the actual problem is that I consider the Zend Framework a sensitive package due to its popularity and don't want to push new releases in blindly. So what's really needed is testers and karma.

If you take a look at the specfile you might realize it's a complex package that requires serious and sensitive care; I appreciate any cooperation based on the same observations and resulting principles for the maintenance of the package.

Please share your thoughts with me.
Comment 2 Sudheer Satyanarayana 2009-04-14 05:57:39 EDT
Hi Alexander,

Thank you for the kind response. 

I have been developing multiple applications with ZF off late. As far as I can tell there's been no b/c break from 1.7.2 to 1.7.7. ZF 1.7.2 contains important bug fixes. 

Because Fedora ships ZF 1.7.2 I checkout 1.7.7 from framework.zend.com/svn to /usr/lib/php/ on my machine. 

I will install the package from testing repo this weekend and see if I can fix existing issues.
Comment 3 Fedora Update System 2009-07-17 07:39:36 EDT
php-ZendFramework-1.8.4-1.PL1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/php-ZendFramework-1.8.4-1.PL1.fc11
Comment 4 Fedora Update System 2009-07-17 07:54:36 EDT
php-ZendFramework-1.8.4-1.PL1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/php-ZendFramework-1.8.4-1.PL1.fc10
Comment 5 Fedora Update System 2009-07-22 17:43:32 EDT
php-ZendFramework-1.8.4-2.PL1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-ZendFramework'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7816
Comment 6 Alexander Kahl 2009-07-27 03:01:04 EDT
Ping. Need your karma in Bodhi.
Comment 7 Fedora Update System 2009-08-04 20:29:51 EDT
php-ZendFramework-1.8.4-2.PL1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-08-04 20:36:42 EDT
php-ZendFramework-1.8.4-2.PL1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.