Bug 495414 - (herman) no fonts with nouveau on nv50 (gtx260)
no fonts with nouveau on nv50 (gtx260)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 17:26 EDT by Pär Eriksson
Modified: 2009-04-16 01:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 01:52:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (41.97 KB, patch)
2009-04-12 17:26 EDT, Pär Eriksson
no flags Details | Diff
lsmod (1.97 KB, text/x-log)
2009-04-12 17:28 EDT, Pär Eriksson
no flags Details
lspci (7.72 KB, text/x-log)
2009-04-12 17:29 EDT, Pär Eriksson
no flags Details
Xorg.0.log (94.83 KB, text/x-log)
2009-04-12 17:29 EDT, Pär Eriksson
no flags Details
xorg.conf disabling exa composite (283 bytes, text/plain)
2009-04-13 01:51 EDT, Ben Skeggs
no flags Details

  None (edit)
Description Pär Eriksson 2009-04-12 17:26:50 EDT
Created attachment 339261 [details]
dmesg

Description of problem:

1. no fonts or icons in GNOME/KDE with nouveau on nv50 (geforce gtx260)
2. the progressbar from plymouth and text "sticks to the screen" when i switch between vt's 

Version-Release number of selected component (if applicable):

Fedora-11-Snap1-x86_64-Live 2009-04-10

How reproducible:

boot from the live cd 

Steps to Reproduce:
1. boot with or without nouveau.modeset=1
2. GDM/KDM starts without fonts or icons
3.
  
Actual results:

no fonts or icons

Expected results:

fonts and icons

Additional info:

plymouth loades and selects correct res from what I can tell

attached output of lspci, lsmod, dmesg and Xorg.0.log

will try to get renouveau and MmioTrace

please tell me if you need anything more! 

thanks for working on nouveau!
Comment 1 Pär Eriksson 2009-04-12 17:28:53 EDT
Created attachment 339262 [details]
lsmod
Comment 2 Pär Eriksson 2009-04-12 17:29:16 EDT
Created attachment 339263 [details]
lspci
Comment 3 Pär Eriksson 2009-04-12 17:29:44 EDT
Created attachment 339264 [details]
Xorg.0.log
Comment 4 Ben Skeggs 2009-04-13 01:51:14 EDT
Hmm, I don't think nouveau sets up the 3D engine properly on those chipsets as of yet.  I really need to get hold of the hw to find out what's up there.

Can you see how things look with the attached xorg.conf ?  This disables the acceleration that depends on the 3D engine working, which will hopefully make things render correctly again.  It'll be slower than usual, but better than not having fonts!

If this works for you I'll commit a patch to do this by default on all cards of that series.
Comment 5 Ben Skeggs 2009-04-13 01:51:52 EDT
Created attachment 339279 [details]
xorg.conf disabling exa composite
Comment 6 Pär Eriksson 2009-04-13 04:36:06 EDT
its very very slow, but it worked!

I'm be happy to run any test you might need, I've been looking in to renouveau and MmioTrace

renouveau got a segment fault on Ubuntu 9.04 - im going to try it on fedora. im still not really sore what to do with MmioTrace
Comment 7 Ben Skeggs 2009-04-13 04:47:55 EDT
Thanks, that confirms it's definitely the 3D engine malfunctioning.  I'll commit a patch to disable composite for the moment until I can find out why it doesn't work.

I highly doubt Xv will work either as it uses the 3D engine too.  Are you able to run gstreamer-properties and run the video test on the "X Window System (X11/XShm/Xv)" plugin and see if anything displays at all?

Renouveau dumps are probably what's needed here, unless I made a mistake when doing the kernel-side support for your chipset.  I'll double-check that tonight.  Trouble is, renouveau barely works (if at all) on the latest binary drivers.

mmio-trace however, is easy.  You just need to install the kernel-debug package (which has mmio-trace compiled in), and then follow the instructions at http://nouveau.freedesktop.org/wiki/MmioTrace.

Thanks again!
Ben.
Comment 8 Pär Eriksson 2009-04-13 10:30:15 EDT
No, X Window System (X11/XShm/Xv) Test doesn't show anything at all...

i will try Renouveau with older drivers later today (i think)
Comment 9 Ben Skeggs 2009-04-13 21:13:15 EDT
Ok, I didn't expect it would.  Thanks.  If you update to xorg-x11-drv-nouveau-0.0.12-26.20090413git7100c06.fc11 your card should work without an xorg.conf, and be quite a bit faster.  Note it's still not working correctly, and you won't have Xv still.
Comment 10 Pär Eriksson 2009-04-15 07:09:08 EDT
hello

i have tested xorg-x11-drv-nouveau-0.0.12-26.20090413git7100c06.fc11 and it works really good!

Note You need to log in before you can comment on or make changes to this bug.