Bug 495425 - Importing package metadata is extremely slow for ISS
Importing package metadata is extremely slow for ISS
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Jeff Browning
:
Depends On:
Blocks: 457071
  Show dependency treegraph
 
Reported: 2009-04-12 20:49 EDT by Jeff Browning
Modified: 2009-08-10 11:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 10:08:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2009-04-12 20:49:27 EDT
Description of problem:
The importing package metadata step is very slow when syncing packages from a master to a slave. Even syncing one package can take hours. I am unsure if this is due to our hardware performance, or if it is code related, but it has made testing very difficult.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090403.2-i386-embedded-oracle.iso

How reproducible:
Not always, but most of the time.

Steps to Reproduce:
1. Sync a channel from a master to a slave.
2. Observe the time it takes to complete the Importing Package Metadata step.
  
Actual results:
The import step takes hours to complete for a single channel.

Expected results:
Something more manageable than hours per channel.

Additional info:
Master: rlx-0-06
Slave: fjs-0-01
Comment 1 Pradeep Kilambi 2009-04-14 10:08:17 EDT
Your first channel syncs are expected to be slow as the exporter on the master needs to generate the entire metadata cache for 7000+ packages. Once the first syncs are complete the subsequent syncs should be quick. 

Try this:

* run your first sync for a given channel. (wait until it generates all the metadata)

* Now create another slave and try syncing the same channel. Now it should be at least three times faster.

Feel free to reopen if you still see issues after the first sync.
Comment 2 Tomas Lestach 2009-08-10 11:34:48 EDT
Stage validation -> ClosedValid

Note You need to log in before you can comment on or make changes to this bug.