This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 495444 - System hangs after restart triggered from GNOME menu - needs ctrl-alt-del to proceed
System hangs after restart triggered from GNOME menu - needs ctrl-alt-del to ...
Status: CLOSED DUPLICATE of bug 495326
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 04:36 EDT by Joachim Frieben
Modified: 2009-04-29 06:42 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 06:42:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Corresponding excerpt from /var/log/messages (1.57 KB, text/plain)
2009-04-13 04:36 EDT, Joachim Frieben
no flags Details
excerpt from /var/log/messages (5.97 KB, text/plain)
2009-04-28 12:09 EDT, Josep
no flags Details
GDM backtrace and DRM errors from /var/log/messages (35.54 KB, text/plain)
2009-04-28 12:56 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2009-04-13 04:36:04 EDT
Created attachment 339297 [details]
Corresponding excerpt from /var/log/messages

Description of problem:
On a current "rawhide" system, selecting the restart option from the GNOME menu terminates GNOME and X, but then the system is stuck in a virtual console.

Version-Release number of selected component (if applicable):
gnome-session-2.26.0.90-1.fc11.i586

How reproducible:
Always.

Steps to Reproduce:
1. Choose restart action from GNOME menu.
  
Actual results:
GNOME and X terminate. User faces a virtual console announcing that the system is going to reboot but nothing happens.

Expected results:
System restarts.

Additional info:
- Typing ctrl-alt-del allows the reboot to continue. 
- reboot action completes successfully when the corresponding GDM button is
  clicked.
Comment 1 Mike Chambers 2009-04-28 05:46:05 EDT
Seeing the same thing as well as others from mailing list.
Comment 2 Matthias Clasen 2009-04-28 11:15:16 EDT
Apr 13 10:05:16 daily kernel: [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 1


Makes it sound like a driver issue, potentially. Moving to the X side for now.
Comment 3 Adam Pribyl 2009-04-28 11:24:35 EDT
Hm.. for me this happens with i686-PAE kernel, but seems OK with i586 kernel.
Comment 4 Matěj Cepl 2009-04-28 11:32:57 EDT
Joachim, please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Josep 2009-04-28 12:09:07 EDT
Created attachment 341597 [details]
excerpt from /var/log/messages

Matej: I have the same problem, or at least the same symptoms, but with an nvidia card.

Here is more detailed info about my symptoms:

I'm running rawhide and I often can not turn off or restart the computer from the gnome menus (it seems to work from GDM).
What happens normally is that when choosing to restart (or turn off) the computer, the panels and all desktop icons will disappear, except for the background picture, which is usually shifted to the right with some garbage on the screen, and there it stays.
I can go back to the consoles with <alt><ctrl><Fx>, but I can not type anything, and so I am not able to log in there.
The only thing I can do to turn off the computer is pressing the power off button, fedora then reacts instantly by shutting down the computer normally.


Looking at /var/log/messages it seems that GDM is crashing, see attached file.

Please let me know if this should be filed as a separate bug. Thanks.
Comment 6 Joachim Frieben 2009-04-28 12:56:19 EDT
Created attachment 341608 [details]
GDM backtrace and DRM errors from /var/log/messages

This appears to be a kernel (DRM) issue which only occurs for the kernel.i586 package but not the kernel-PAE.i686 one. Reassigning to component kernel.
Comment 7 Josep 2009-04-28 13:30:20 EDT
I'm actually seeing it on a kernel-PAE.i686 (kernel-PAE-2.6.29.1-102.fc11.i686), although I have an NVidia graphics card.
Comment 8 Josep 2009-04-29 03:59:36 EDT
It was suggested in the test mailing list that this might be the same as bug #495326
Looking at the log messages, they certainly looks very alike (rc6 being killed).
Comment 9 Adam Pribyl 2009-04-29 06:42:10 EDT
OK this certainly is a dupe, but none of bugs is clear in what component this shoudl be assigned to. Seems the rc6 kill is the main cause for now.

*** This bug has been marked as a duplicate of bug 495326 ***

Note You need to log in before you can comment on or make changes to this bug.