Bug 495449 - qemu-kvm can not execute winxp vm with -vga std or -vga vmware
qemu-kvm can not execute winxp vm with -vga std or -vga vmware
Status: CLOSED DUPLICATE of bug 494376
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 05:30 EDT by Peng Huang
Modified: 2009-04-19 06:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-19 06:32:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peng Huang 2009-04-13 05:30:05 EDT
Description of problem:
qemu-kvm can not execute winxp vm with -vga std or -vga vmware

Version-Release number of selected component (if applicable):
qemu-0.10-7.fc11.x86_64

How reproducible:


Steps to Reproduce:
1. Use a winxp disk image to start qemu-kvm with -vga std or -vga vmware
2. 
3.
  
Actual results:
$ sudo qemu-kvm -vga std -boot c -hda winxp.raw
create_userspace_phys_mem: Invalid argument
kvm_cpu_register_physical_memory: failed


Expected results:



Additional info:
I checked the code. the problem is because of qemu register a vga bios mem region without 4k mem align. If I change the mem align to 4K, qemu-kvm can execute Linux vm with -vga std successfully. But for winxp, I can see the bios screen, but can not boot up winxp successfully.
Comment 1 Mark McLoughlin 2009-04-19 06:32:34 EDT
Thanks - this is a known issue and Glauber is working to get it fixed upstream

*** This bug has been marked as a duplicate of bug 494376 ***
Comment 2 Mark McLoughlin 2009-04-19 06:40:41 EDT
Ah, sorry Peng - I see it was you that started the discussion on qemu-devel with a patch :-)

Note You need to log in before you can comment on or make changes to this bug.