Bug 495462 - Pulseaudio crashes on alsa assertion
Pulseaudio crashes on alsa assertion
Status: CLOSED DUPLICATE of bug 472339
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
i586 Linux
low Severity urgent
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 06:32 EDT by Ruben Vermeersch
Modified: 2009-04-13 10:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 10:55:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruben Vermeersch 2009-04-13 06:32:45 EDT
When playing audio (either through banshee or totem-gstreamer, which both use pulseaudio), pulseaudio aborts after a few minutes with following error:

E: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294952652 bytes (24347804 ms).
E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
E: alsa-util.c: snd_pcm_dump():
E: alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0
E: alsa-util.c: Its setup is:
E: alsa-util.c:   stream       : PLAYBACK
E: alsa-util.c:   access       : MMAP_INTERLEAVED
E: alsa-util.c:   format       : S16_LE
E: alsa-util.c:   subformat    : STD
E: alsa-util.c:   channels     : 2
E: alsa-util.c:   rate         : 44100
E: alsa-util.c:   exact rate   : 44100 (44100/1)
E: alsa-util.c:   msbits       : 16
E: alsa-util.c:   buffer_size  : 16384
E: alsa-util.c:   period_size  : 16384
E: alsa-util.c:   period_time  : 371519
E: alsa-util.c:   tstamp_mode  : ENABLE
E: alsa-util.c:   period_step  : 1
E: alsa-util.c:   avail_min    : 16384
E: alsa-util.c:   period_event : 0
E: alsa-util.c:   start_threshold  : -1
E: alsa-util.c:   stop_threshold   : 1073741824
E: alsa-util.c:   silence_threshold: 0
E: alsa-util.c:   silence_size : 0
E: alsa-util.c:   boundary     : 1073741824
E: rtpoll.c: Assertion 'usec <= ((pa_usec_t) 1000000ULL)*60ULL*60ULL' failed at pulsecore/rtpoll.c:548, function pa_rtpoll_set_timer_relative(). Aborting.

Using alsa directly works fine (and is currently my only option to get any sound output).

This is rawhide:
$ rpm -q pulseaudio
pulseaudio-0.9.15-9.test8.fc11.i586
$ uname -a
Linux tokyo 2.6.29.1-68.fc11.i586 #1 SMP Sat Apr 11 02:06:17 EDT 2009 i686 i686 i386 GNU/Linux
$ rpm -q alsa-lib
alsa-lib-1.0.19-3.fc11.i586
Comment 1 Lennart Poettering 2009-04-13 10:55:41 EDT

*** This bug has been marked as a duplicate of bug 472339 ***

Note You need to log in before you can comment on or make changes to this bug.