Bug 495469 - internal compiler error: in expand_expr_real_1, at expr.c:9199
internal compiler error: in expand_expr_real_1, at expr.c:9199
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc (Show other bugs)
5.3
ppc64 All
low Severity medium
: rc
: ---
Assigned To: Jakub Jelinek
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 07:00 EDT by IBM Bug Proxy
Modified: 2009-09-02 07:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:43:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source (1016.62 KB, application/octet-stream)
2009-04-13 07:00 EDT, IBM Bug Proxy
no flags Details
backport from FSF mainline (2.61 KB, text/plain)
2009-04-13 07:01 EDT, IBM Bug Proxy
no flags Details
minimized testcase (869 bytes, text/plain)
2009-04-13 07:01 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2009-04-13 07:00:47 EDT
=Comment: #0=================================================
William M. Schmidt <will_schmidt@vnet.ibm.com> - 

preprocessed source

---Problem Description---
During a ppc64 kernel build ,  an ICE is occurring. 

drivers/video/cirrusfb.c: In function ‘cirrusfb_set_par_foo’:
drivers/video/cirrusfb.c:475: internal compiler error: in expand_expr_real_1, at expr.c:9199

 Contact Information = willschm@us.ibm.com 
 
---uname output---
Linux gleep4.rchland.ibm.com 2.6.28 #5 SMP Thu Jan 22 10:22:10 CST 2009 ppc64 ppc64 ppc64 GNU/Linux
 
Machine Type = JS22 
 
=---Steps to Reproduce---
 do a kernel build.
attempt to build using (attached) preprocessed source.

I've hit this with both 
gcc version 4.1.2 20071124 (Red Hat 4.1.2-42)
and
gcc version 4.3.1 20080606 (Advance-Toolchain-05) (GCC)

---GCC - Power Component Data---
=Comment: #1=================================================
Janis M. Johnson <janis@us.ibm.com> - 
The bug exists in FSF GCC 4.3.1 but not in FSF GCC 4.3.2; it was fixed on the 4.3 branch with

    r139032 | jakub | 2008-08-12 18:36:28 +0000 (Tue, 12 Aug 2008) | 7 lines

        PR middle-end/37014
        * expr.c (expand_expr_real_1): Handle TRUTH_ANDIF_EXPR
        and TRUTH_ORIF_EXPR.
        * dojump.c (do_jump): Likewise.
        * gcc.c-torture/compile/20080812-1.c: New test.

    http://gcc.gnu.org/viewcvs?view=rev&rev=139032
I'll append a minimized testcase.
I'll try applying the patch against 4.3 to the FSF 4.1 branch, since the RHEL5 compiler is 4.1.
=Comment: #2=================================================
Janis M. Johnson <janis@us.ibm.com> - 

minimized testcase

The minimized testcase gets the ICE when compiled with -m64 and -Os or -O1.
=Comment: #3=================================================
Janis M. Johnson <janis@us.ibm.com> - 
Jakub's patch to 4.3 backports nicely to 4.1.  I'll attach it after full testing.
=Comment: #4=================================================
Janis M. Johnson <janis@us.ibm.com> - 

backport from FSF mainline
Backported patch, applied to FSF 4.1 branch and bootstrapped on powerpc64-linux for all languages
except Ada and regtested with -m32/-m64.
Comment 1 IBM Bug Proxy 2009-04-13 07:00:57 EDT
Created attachment 339308 [details]
preprocessed source
Comment 2 IBM Bug Proxy 2009-04-13 07:01:01 EDT
Created attachment 339309 [details]
backport from FSF mainline
Comment 3 IBM Bug Proxy 2009-04-13 07:01:06 EDT
Created attachment 339310 [details]
minimized testcase
Comment 6 Petr Muller 2009-05-07 09:45:42 EDT
qe_ack+, there are testcases available
Comment 10 IBM Bug Proxy 2009-07-02 17:01:20 EDT
------- Comment From will_schmidt@vnet.ibm.com 2009-07-02 16:53 EDT-------
Seems to be working OK with  "gcc version 4.1.2 20080704 (Red Hat 4.1.2-46)" in the 5.4 beta.    the cirrusfb code built without generating an ICE message.

Marking as closed.

Thanks,
-Will
Comment 12 errata-xmlrpc 2009-09-02 07:43:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1376.html

Note You need to log in before you can comment on or make changes to this bug.