Bug 495478 - Document use of mke2fs -F for creating large file systems
Document use of mke2fs -F for creating large file systems
Status: CLOSED DUPLICATE of bug 241285
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 07:38 EDT by Bryn M. Reeves
Modified: 2009-04-18 10:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-18 10:17:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2009-04-13 07:38:17 EDT
Description of problem:
It is now possible to create ext3 file systems of 8-16TiB in size (>2^31-1 blocks) by specifying the '-F' switch to the mke2fs/mkfs.ext3 command. This is documented in the following kbase note:

http://kbase.redhat.com/faq/docs/DOC-9855

But is not mentioned in the documentation for the e2fsprogs package itself.

The larger file system size limits are fully supported as of RHEL-5.1 so it would be useful to have this documented. E.g. adding the following extra statement to the existing documentation of -F in man 8 mke2fs:

      -F     Force mke2fs to run, even if the specified device is not a block 
             special device, or appears to be mounted. This option is required 
             to create file systems larger than 8TB.

Version-Release number of selected component (if applicable):
e2fsprogs-1.39-15.el5

How reproducible:
100%

Steps to Reproduce:
1. Examine man pages or /usr/share/doc/e2fsprogs-*/*
  
Actual results:
No mention of use of -F to create large file systems

Expected results:
Document use of above switch

Additional info:
Comment 1 Eric Sandeen 2009-04-18 10:12:38 EDT
Yep, we should fix this up.  Since > 8T is supposed to be formally supported, we should just remove the need for the "-F" in the >8T case, I suppose.

Thanks,
-Eric
Comment 2 Eric Sandeen 2009-04-18 10:17:02 EDT
Oh, and in fact it is already removed in e2fsprogs-1.39-22 as part of the changes for bug 241285.

-Eric

*** This bug has been marked as a duplicate of bug 241285 ***

Note You need to log in before you can comment on or make changes to this bug.