Bug 495509 - missing sisfb kernel module
missing sisfb kernel module
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 11:20 EDT by pj
Modified: 2009-06-09 01:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 01:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pj 2009-04-13 11:20:17 EDT
Description of problem:
sisfb kernel module not included in kernel


Version-Release number of selected component (if applicable):
Fedora 11 beta2 and beta 3

How reproducible:
Everytime

Steps to Reproduce:
1. modprobe sisfb
2.
3.
  
Actual results:
no module found

Expected results:
module loaded

Additional info:
The "vesafb" mostly works, but has frequent horizontal line interference on an Asus laptop model 5000 ( 5002wlci ) with integrated sis video. The sisfb from F10 was much better.

Additionally, without the either the vesafb or sisfb, the display is VERY difficult to make out.

There is still the sisfb.h and sisfb.txt to be found in various .rpm's, but no indication that is should be gone.
Comment 1 pj 2009-04-13 11:41:11 EDT
Sorry, it's a Acer laptop model 5000 ( 5002wlci ) with integrated sis video, not Asus.
Comment 2 Chuck Ebbert 2009-04-13 12:18:47 EDT
(In reply to comment #2)
> The "vesafb" mostly works, but has frequent horizontal line interference on an
> Asus laptop model 5000 ( 5002wlci ) with integrated sis video. The sisfb from
> F10 was much better.

AFAICT there has never been a sisfb driver in F10.

[root@as ~]# rpm -q kernel
kernel-2.6.27.9-159.fc10.x86_64
kernel-2.6.27.12-170.2.5.fc10.x86_64
kernel-2.6.27.15-170.2.24.fc10.x86_64
kernel-2.6.27.19-170.2.35.fc10.x86_64
kernel-2.6.27.21-170.2.56.fc10.x86_64
[root@as ~]# find /lib/modules -name sisfb\*
[root@as ~]#
Comment 3 pj 2009-04-13 13:04:11 EDT
I use this laptop to test most anything. I lost the changes to the Fedora or CentOS that was on it. I did a fresh install and wiped it. It may have been Fedora 9 or CentOS 5.3. I just thought it was 10. Fedora 8 did not have any issue at all and required not intervention IIRC.

It would appear that this should still be a viable module according to a "yum provides *sisfb*" since there is a .h and the .txt. This is from a F10 box since the 11beta laptop is not on:

kernel-doc-2.6.27.21-170.2.56.fc10.noarch : Various documentation bits found in the kernel source
Repo        : Updates
Matched from:
Filename    : /usr/share/doc/kernel-doc-2.6.27.21/Documentation/fb/sisfb.txt



kernel-devel-2.6.27.19-170.2.35.fc10.i686 : Development package for building kernel modules to match the kernel
Repo        : installed
Matched from:
Filename    : /usr/src/kernels/2.6.27.19-170.2.35.fc10.i686/include/video/sisfb.h
Comment 4 Chuck Ebbert 2009-04-13 18:46:59 EDT
I looked all the way back to Fedora 7 and the sisfb driver wasn't in there either. So it must have been CentOS.
Comment 5 pj 2009-04-13 22:18:57 EDT
I now have no clue why I have been holding to the sisfb. I can't even verify why I even thought I needed it... But at least the file /usr/share/doc/kernel-doc-2.6.29.1/Documentation/fb/sisfb.txt clearly states, "Kernels >= around 2.6.3 do not need sisfb any longer for DRI/DRM memory management."

So, I guess I stuck with a default install on this laptop that is not able to display much usable info in a GUI mode or the vesafb module that kinda glitches on a frequent basis. I will make an attempt to pass some of the kernel args noted in the above text file.

On a side note: the CentOS that could have been on the box was 5.3. That kernel version does not seem to fall into the category that should have had the module (2.6.18-redhatish).

Note You need to log in before you can comment on or make changes to this bug.