Bug 495510 - Rhythmbox Crashes when loading an internet radio audio stream
Rhythmbox Crashes when loading an internet radio audio stream
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-04-13 11:30 EDT by Justin Phelps
Modified: 2015-05-07 12:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 21:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Phelps 2009-04-13 11:30:59 EDT
Description of problem:
When attempting to load an internet radio audio stream, rhythmbox crashes with the following outputted to the console.

$ rhythmbox

GThread-ERROR **: file gthread-posix.c: line 171 (g_mutex_free_posix_impl): error 'Device or resource busy' during 'pthread_mutex_destroy ((pthread_mutex_t *) mutex)'
aborting...
rhythmbox: xcb_io.c:176: process_responses: Assertion `!(req && current_request && !(((long) (req->sequence) - (long) (current_request)) <= 0))' failed.
Multiple segmentation faults occurred; can't display error dialog

Version-Release number of selected component (if applicable):


How reproducible:
Open rhythmbox and attempt to load an internet radio stream.

Steps to Reproduce:
1. Open rhythmbox
2. Attempt to load an internet radio stream.
  
Actual results:
Program crashes without an error (except at console)

Expected results:
Audio should play.

Additional info:

$ rhythmbox --version
GNOME rhythmbox 0.12.0

$ yum info rhythmbox
Loaded plugins: refresh-packagekit
adobe-linux-i386                                                          17/17
Installed Packages
Name       : rhythmbox
Arch       : i586
Version    : 0.12.0
Release    : 4.fc11
Size       : 10 M
Repo       : installed
Summary    : Music Management Application
URL        : http://projects.gnome.org/rhythmbox/
License    : GPLv2+ with exceptions and GFDL
Description: Rhythmbox is an integrated music management application based on
           : the powerful GStreamer media framework. It has a number of
           : features, including an easy to use music browser, searching and
           : sorting, comprehensive audio format support through GStreamer,
           : Internet Radio support, playlists and more.
           : 
           : Rhythmbox is extensible through a plugin system.
Comment 1 Matthias Clasen 2009-04-13 14:17:07 EDT
Looks like a segfault somewhere inside libsoup


(gdb) bt
#0  0x0000003b6ee33435 in *__GI_raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x0000003b6ee34caa in *__GI_abort () at abort.c:88
#2  0x0000003b70642510 in IA__g_logv (log_domain=<value optimized out>, 
    log_level=<value optimized out>, format=<value optimized out>, 
    args1=0x7fffef8a2d60) at gmessages.c:506
#3  0x0000003b706425a3 in IA__g_log (
    log_domain=0x46db <Address 0x46db out of bounds>, log_level=18332, 
    format=0x6 <Address 0x6 out of bounds>) at gmessages.c:526
 #4  0x0000003b72202526 in g_mutex_free_posix_impl (mutex=0x7fffe807d720)
    at gthread-posix.c:171
#5  0x00007fffdadcb8db in soup_proxy_resolver_gnome_init (
    resolver_gnome=<value optimized out>) at soup-proxy-resolver-gnome.c:139
#6  0x0000003b70e2c287 in IA__g_type_create_instance (
    type=<value optimized out>) at gtype.c:1674
#7  0x0000003b70e10b7c in g_object_constructor (type=18139, 
    n_construct_properties=18332, construct_params=0x6) at gobject.c:1338
#8  0x0000003b70e11b99 in IA__g_object_newv (
    object_type=<value optimized out>, n_parameters=0, 
    parameters=<value optimized out>) at gobject.c:1215
#9  0x0000003b70e126f5 in IA__g_object_new_valist (
    object_type=140737086189888, first_property_name=0x0, 
    var_args=0x7fffef8a3270) at gobject.c:1278
---Type <return> to continue, or q <return> to quit--- 
#10 0x0000003b70e1284c in IA__g_object_new (object_type=140737086189888, 
    first_property_name=0x0) at gobject.c:1060
#11 0x0000003b8742f7f7 in soup_session_add_feature_by_type (
    session=0x7fffdc0032c0, feature_type=140737086189888)
    at soup-session.c:1517
#12 0x0000003b70e11d0d in object_set_property (nqueue=<value optimized out>, 
    value=<value optimized out>, pspec=<value optimized out>, 
    object=<value optimized out>) at gobject.c:942
#13 IA__g_object_newv (nqueue=<value optimized out>, 
    value=<value optimized out>, pspec=<value optimized out>, 
    object=<value optimized out>) at gobject.c:1237
#14 0x0000003b70e125e1 in IA__g_object_new_valist (
    object_type=140737086201760, first_property_name=0x0, 
    var_args=0x7fffef8a3590) at gobject.c:1319
#15 0x0000003b87431dad in soup_session_async_new_with_options (
    optname1=0x7fffdafd3118 "async-context") at soup-session-async.c:104
#16 0x00007fffdafd1f22 in soup_buffer_get_owner () at soup-message-body.c:200
#17 0x0000003b85c16431 in gst_base_src_start (basesrc=0x7fffe80740e0)
    at gstbasesrc.c:2454
#18 0x0000003b85c17c20 in gst_base_src_activate_push (pad=0x7fffe8040a10, 
    active=<value optimized out>) at gstbasesrc.c:2677
#19 0x0000003b8585b28b in gst_pad_activate_push (pad=0x7fffe8040a10, active=1)
    at gstpad.c:897
Comment 2 Matthias Clasen 2009-04-13 14:21:45 EDT
Upstream bug is http://bugzilla.gnome.org/show_bug.cgi?id=578645
Fix will be in 2.26.1 later today.
Comment 3 Matthias Clasen 2009-04-13 21:35:04 EDT
libsoup-2.26.1 has been built

Note You need to log in before you can comment on or make changes to this bug.