Bug 495524 - 855: i915 module fails to load ("no such device" errors go back to i2c-core)
855: i915 module fails to load ("no such device" errors go back to i2c-core)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 12:52 EDT by Mario Chacon
Modified: 2009-04-30 19:52 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 19:28:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (3.33 KB, text/plain)
2009-04-13 12:52 EDT, Mario Chacon
no flags Details
xorg.log (26.66 KB, text/plain)
2009-04-13 12:53 EDT, Mario Chacon
no flags Details
xorg intel 2.7 (3.33 KB, text/plain)
2009-04-20 09:00 EDT, Mario Chacon
no flags Details
xorg log intel 2.7 (75.36 KB, text/plain)
2009-04-20 09:00 EDT, Mario Chacon
no flags Details
dmesg.log (20.55 KB, text/plain)
2009-04-29 08:03 EDT, Mario Chacon
no flags Details
xorg.log (26.66 KB, text/plain)
2009-04-30 14:53 EDT, Mario Chacon
no flags Details
xorg.conf (3.33 KB, application/octet-stream)
2009-04-30 14:54 EDT, Mario Chacon
no flags Details

  None (edit)
Description Mario Chacon 2009-04-13 12:52:51 EDT
Created attachment 339341 [details]
xorg.conf

Description of problem:
Hello:

I got software renderize with glxgears -info and I saw this error in the
Xorg.log:

(II) intel(0): Kernel reported 232704 total, 1 used
(II) intel(0): I830CheckAvailableMemory: 930812 kB available
drmOpenDevice: node name is /dev/dri/card0
[drm] failed to load kernel module "i915"
(WW) intel(0): Failed to open DRM device
(**) intel(0): Framebuffer compression enabled
(**) intel(0): Tiling enabled
(==) intel(0): VideoRam: 131072 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(WW) intel(0): xf86AllocateGARTMemory: allocation of 1536 pages failed
    (Cannot allocate memory)
(WW) intel(0): Allocation error, framebuffer compression disabled
(WW) intel(0): xf86AllocateGARTMemory: allocation of 10 pages failed
    (Cannot allocate memory)

It's possible to fix it?

Salu2..
masch...


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mario Chacon 2009-04-13 12:53:22 EDT
Created attachment 339342 [details]
xorg.log
Comment 2 Adam Williamson 2009-04-16 17:26:28 EDT
What are you running exactly - Rawhide? F11 Beta? F11 Snapshot?

What kernel package are you running?

What's the output of this, run as root:

lsmod | grep i915

? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Mario Chacon 2009-04-17 07:39:58 EDT
I have installed the Snapshot and updated to the latest version.
kernel version: 2.6.29.1-70.fc11.i586
I got nothing when I run lsmod | grep i915.

Thanks..
Salu2...
Comment 4 Adam Williamson 2009-04-17 13:05:49 EDT
Can you please do this?

Open a root console, and run 'tail -f /var/log/messages'. Leave that running.

Open another root console that doesn't overlap the first. Run 'modprobe i915' in this console. This should result in several new lines showing up in the first console. Can you copy / paste, or attach, those lines? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Mario Chacon 2009-04-17 13:18:14 EDT
[root@localhost ~]# modprobe i915
WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
WARNING: Error inserting i2c_core (/lib/modules/2.6.29.1-70.fc11.i586/kernel/drivers/i2c/i2c-core.ko): No such device
WARNING: Error inserting i2c_algo_bit (/lib/modules/2.6.29.1-70.fc11.i586/kernel/drivers/i2c/algos/i2c-algo-bit.ko): No such device
WARNING: Error inserting drm (/lib/modules/2.6.29.1-70.fc11.i586/kernel/drivers/gpu/drm/drm.ko): No such device
FATAL: Error inserting i915 (/lib/modules/2.6.29.1-70.fc11.i586/kernel/drivers/gpu/drm/i915/i915.ko): No such device

No log in the messages.

Salu2..
masch...
Comment 6 Adam Williamson 2009-04-17 13:38:37 EDT
Thanks...one more thing - can you post the contents of that /etc/modprobe.conf file? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Mario Chacon 2009-04-17 14:27:43 EDT
It's empty.
Comment 8 Adam Williamson 2009-04-17 16:44:14 EDT
OK. Looks like some kind of kernel issue then. Assigning to kernel, keeping intel maintainers in CC in case they can shed any light.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Mario Chacon 2009-04-20 08:59:28 EDT
I tried with the new kernel 2.6.29.1-100.fc11.i586 and xorg-x11-drv-intel-2.7.0-1.fc11.i586 and I have another logs, please see new attachs.

Salu2...
masch...
Comment 10 Mario Chacon 2009-04-20 09:00:07 EDT
Created attachment 340336 [details]
xorg intel 2.7
Comment 11 Mario Chacon 2009-04-20 09:00:29 EDT
Created attachment 340337 [details]
xorg log intel 2.7
Comment 12 Mario Chacon 2009-04-22 00:21:02 EDT
Is it going to be fix it in F11?
Comment 13 Mario Chacon 2009-04-24 23:31:47 EDT
I have talk with intel developers and they told me that it's a Fedora bug, not a driver problem, Is it correct?
Comment 14 Otto Rey 2009-04-25 14:03:34 EDT
If it's a Fedora bug instead of intel driver problem, we should fix it before F11 release to keep excelente intel video support in Fedora out of the box.
Comment 15 Mario Chacon 2009-04-27 14:06:59 EDT
Is there any way to recompile some source to make it work on my machine??
Comment 16 Kyle McMartin 2009-04-27 15:05:44 EDT
Attach dmesg?
Comment 17 Mario Chacon 2009-04-27 15:21:14 EDT
How can I do it?
Comment 18 Kyle McMartin 2009-04-27 15:33:02 EDT
Type

dmesg >dmesg.log

and attach dmesg.log to this bug?
Comment 19 Mario Chacon 2009-04-29 08:03:08 EDT
Created attachment 341746 [details]
dmesg.log
Comment 20 Mario Chacon 2009-04-29 08:33:00 EDT
Please check my log.
Comment 21 Mario Chacon 2009-04-30 14:51:11 EDT
Now it's works using the latest version of the kernel and intel driver, but I have to use the option Tiling(false) to synchronize the video and  got this warning:

II)         composite (RENDER acceleration)
(==) intel(0): Backing store disabled
(==) intel(0): Silken mouse enabled
(II) intel(0): Initializing HW Cursor
(II) intel(0): No memory allocations
(II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(II) intel(0): DPMS enabled
(==) intel(0): Intel XvMC decoder disabled
(WW) intel(0): Disabling Xv because no adaptors could be initialized.
(II) intel(0): direct rendering: DRI2 Enabled
(--) RandR disabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYN

Watching the intel help it's says that if I enable this option:
In most cases (especially for complex rendering), tiling dramatically improves performance.
Why do I need to use it??

Salu2...
masch...

PD: I have attached the new Xorg log and conf.
Comment 22 Mario Chacon 2009-04-30 14:53:18 EDT
Created attachment 341978 [details]
xorg.log
Comment 23 Mario Chacon 2009-04-30 14:54:15 EDT
Created attachment 341979 [details]
xorg.conf
Comment 24 Adam Williamson 2009-04-30 19:28:29 EDT
So, to be clear, you no longer have the problem with the i915 module with latest rawhide?

If that's the case, please file a new bug for your new problem. Tracking multiple bugs in a single report is impossible to do effectively. Thanks!
Comment 25 Mario Chacon 2009-04-30 19:52:29 EDT
Yes, it's working!!..
Thanks you much!..

I have created a new task with the tiling option: https://bugzilla.redhat.com/show_bug.cgi?id=498543

Note You need to log in before you can comment on or make changes to this bug.