Bug 495527 - Yum update pulls in the wrong kernel-debuginfo-common
Yum update pulls in the wrong kernel-debuginfo-common
Status: CLOSED DUPLICATE of bug 487731
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 13:22 EDT by William Cohen
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 13:25:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Cohen 2009-04-13 13:22:55 EDT
Description of problem:

On Rawhide machine doing update of everything on the machine including the installed kernel-debuginfo* on a 32-bit x86 machine.  Do a "yum upgrade and get the following packages on the list to pull in:

 kernel-debuginfo        i586   2.6.29.1-68.fc11        rawhide-debuginfo 296 M
 kernel-debuginfo-common i686   2.6.29.1-68.fc11        rawhide-debuginfo  36 M

It should be pulling in the i586 version of kernel-debuginfo-common. This causes a conflict later because the machine has the i586 version installed.

Version-Release number of selected component (if applicable):


How reproducible:

Everytime


Steps to Reproduce:
1. Have older kernel-debuginfo and kernel-debuginfo-common installed on machine
2. Do a "yum upgrade --enable=rawhide-debuginfo

  
Actual results:

Get an error 

Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package kernel-debuginfo-common.i586 0:2.6.29.1-54.fc11 set to be erased
--> Processing Dependency: kernel-debuginfo-common-i586 = 2.6.29.1-54.fc11 for package: kernel-debuginfo
--> Running transaction check
---> Package kernel-debuginfo.i586 0:2.6.29.1-54.fc11 set to be erased
--> Finished Dependency Resolution


Expected results:

yum upgrade work on 32-bit machine

Additional info:

A work around:

yum remove kernel-debuginfo-common
yum install --enablerepo=rawhide-debuginfo kernel-debuginfo
Comment 1 seth vidal 2009-04-13 13:25:33 EDT

*** This bug has been marked as a duplicate of bug 487731 ***

Note You need to log in before you can comment on or make changes to this bug.