Bug 495534 - F11 live - (WW) NOUVEAU(0): NV50CheckWriteVClk() timed out. A reboot is probably required now
F11 live - (WW) NOUVEAU(0): NV50CheckWriteVClk() timed out. A reboot is prob...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
11
All Linux
high Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 14:02 EDT by A. Lok
Modified: 2009-10-15 15:36 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-15 15:36:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (1019 bytes, text/plain)
2009-04-13 14:04 EDT, A. Lok
no flags Details
NOUVEAU, booted with external display [hang] (34.21 KB, text/plain)
2009-04-14 03:15 EDT, Lubomir Rintel
no flags Details
NOUVEAU, external monitor plugged in [no hang] (223.79 KB, text/plain)
2009-04-14 03:17 EDT, Lubomir Rintel
no flags Details
NV, booted with external display [no hang] (113.99 KB, text/plain)
2009-04-14 03:20 EDT, Lubomir Rintel
no flags Details
Xorg.0.log (38.21 KB, text/plain)
2009-04-14 12:44 EDT, A. Lok
no flags Details
Xorg.0.log (42.24 KB, text/plain)
2009-06-30 15:35 EDT, A. Lok
no flags Details
/var/log/messages (59.05 KB, text/plain)
2009-06-30 15:36 EDT, A. Lok
no flags Details
Xorg.0.log (50.89 KB, text/plain)
2009-07-01 13:10 EDT, A. Lok
no flags Details
/var/log/messages (76.63 KB, text/plain)
2009-07-01 13:12 EDT, A. Lok
no flags Details

  None (edit)
Description A. Lok 2009-04-13 14:02:26 EDT
Description of problem:

Running the "F11 beta" or "F11 snap 1" live-cd results in a black screen when entering gdm/X. It is not possible to switch back to a console or to quit X.

Through first starting runlevel 3 and attaching a ssh-connection, I was able to get the following from the log-files:

-/var/log/Xorg.0.log:

(WW) NOUVEAU(0): NV50CheckWriteVClk() timed out.
(II) NOUVEAU(0): A reboot is probably required now.

-lspci:
01:00.0 VGA compatible controller: nVidia Corporation G94 [GeForce 9600 GT] (rev a1)

Will attach 'messages' file.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.12-25.20090408gitd8545e6.fc11.x86_64
Comment 1 A. Lok 2009-04-13 14:04:08 EDT
Created attachment 339347 [details]
/var/log/messages
Comment 2 Ben Skeggs 2009-04-13 21:17:51 EDT
Your entire /var/log/Xorg.0.log would be useful.  Thanks!
Comment 3 Lubomir Rintel 2009-04-14 03:15:15 EDT
Created attachment 339437 [details]
NOUVEAU, booted with external display [hang]

Happened with my configuration as well.

Only happens when an external monitor is plugged in at boot time. The external monitor uses 1920x1200 resolution, which is not detected by nouveau driver (I may try with a smaller monitor at home).
Comment 4 Lubomir Rintel 2009-04-14 03:17:24 EDT
Created attachment 339438 [details]
NOUVEAU, external monitor plugged in [no hang]

See comment on top of the log file for details. Did not crash, just the resolution was wrong.
Comment 5 Lubomir Rintel 2009-04-14 03:20:00 EDT
Created attachment 339441 [details]
NV, booted with external display [no hang]

Resolution was detected correctly here.

Please let me know if I can be of any help here, either providing more information or testing a possible fix.

Thanks for the good work on nouveau! :)
Comment 6 A. Lok 2009-04-14 12:44:11 EDT
Created attachment 339524 [details]
Xorg.0.log
Comment 7 A. Lok 2009-04-14 12:50:21 EDT
I've added the full Xorg.0.log above.

As Lubomir Rintel indicates, it indeed might have something to do with dual monitors. I've got 2 monitors attached to my graphics-card using DVI. If I remove the second one, I have no problems.
Comment 8 Ben Skeggs 2009-04-14 19:30:10 EDT
(In reply to comment #5)
> Created an attachment (id=339441) [details]
> NV, booted with external display [no hang]
> 
> Resolution was detected correctly here.
> 
> Please let me know if I can be of any help here, either providing more
> information or testing a possible fix.
> 
> Thanks for the good work on nouveau! :)  
Are you able to provide the output of the "xrandr" command while running nv?  I think what's happening here is nv isn't attempting to program LVDS (it can't, unless the VBIOS has already) and nouveau is (we also can't, but probably try to), hence the hang.

Also, what happens if you set the panel as the primary display in the BIOS and boot with it plugged in?  I'd expect that to work fine.
Comment 9 A. Lok 2009-04-17 13:09:56 EDT
I don't know if it's helpfull, but I've tried to use the 'nv' driver too, but it doesn't work either. (The same black screen, not able to get out of X) The only difference with nouveau is that the 'nv' driver doesn't write anything to Xorg.0.log...

Should I provide  more information? (since the status is 'needinfo')
Comment 10 Adam Williamson 2009-04-23 22:44:41 EDT
if nv works for Lubomir but not Arnout, it rather suggests these are different bugs; Lubomir, you should probably file a separate report. (Right Ben?)

Ben, is there any information required from Arnout for his incarnation?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Ben Skeggs 2009-04-23 23:39:59 EDT
Lubomir, your problem is indeed a separate bug.  I have some thoughts there, but can you file it as a separate bug so this one doesn't get horribly confused, thanks!

Arnout, I don't really have any theories about your issue as of yet.  I'd be interested to know how you fare if you boot with nouveau.modeset=1 on your kernel commandline.
Comment 12 A. Lok 2009-04-25 16:10:16 EDT
If I append nouveau.modeset=1 to the kernel options I get a 'unknown boot option' or something like that. After that, I get the black screen.
Comment 13 xsakis 2009-04-28 20:02:24 EDT
I get the blank screen too. The progress bar loads just fine and i suppose the time when it enters the blank screen is when it's starting to load the graphical interface. My motherboard is GA-M55plus-S3G http://www.gigabyte.com.tw/Support/Motherboard/BIOS_Model.aspx?ProductID=2385#anchor_os with Nvidia 9500 GT graphics card. I tried alpha and the latest preview live cds (32 and 64 bit versions), unfortunately not working.

Is there a command option, when i press the tab, where i can disable nouveau and use the nv driver, to check if the problem is on the new driver?
Comment 14 Adam Williamson 2009-04-28 20:19:50 EDT
Please file a new bug, for now, as it's not yet clear whether or not you have the same issue as the reporter of this one. There are several possible causes of a blank screen when starting the driver.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 xsakis 2009-04-28 21:57:24 EDT
I just figured it out and the problem is with nouveau. I added in the boot options "3" parameter to enter in terminal mode. I logged in as root and executed "Xorg -configure" then i "nano /root/xorg.conf.new" changed the "nouveau" to "vesa" save the file as "xorg.conf" to "/etc/X11" finally executed "startx" and everything worked like a charm. So i suppose there is and issue with nouveau and the nvidia 9500 GT graphics card i have.

If anyone has a problem with a blank screen, can try to do the above changes and give us a feedback.
Comment 16 Adam Williamson 2009-04-28 22:15:46 EDT
Please stop commenting on this report, and file a new one.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Bug Zapper 2009-06-09 09:45:59 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Ben Skeggs 2009-06-29 05:07:13 EDT
(In reply to comment #12)
> If I append nouveau.modeset=1 to the kernel options I get a 'unknown boot
> option' or something like that. After that, I get the black screen.  

Can you grab the a new kernel build from http://koji.fedoraproject.org/koji/buildinfo?buildID=112059 and retry?

You will need to add nouveau.modeset=1 (to enable KMS) and nouveau.uscript=1 (to enable a different code path which will hopefully fix your issues) to your boot options.  If this still doesn't work, I'd be interested in seeing a kernel log with the above two options *and* drm.debug=1.

Thanks!
Comment 19 A. Lok 2009-06-30 15:34:03 EDT
(In reply to comment #18)
> Can you grab the a new kernel build from
> http://koji.fedoraproject.org/koji/buildinfo?buildID=112059 and retry?

Yes, I've got a fresh install from a F11 x86-64-livecd. Then grabbed 'kernel-2.6.29.5-201.fc11' from koji, and 'kernel-firmware-2.6.31-0.33.rc1.git2.fc12.noarch' from rawhide which it needed as a dependency.

> You will need to add nouveau.modeset=1 (to enable KMS) and nouveau.uscript=1
> (to enable a different code path which will hopefully fix your issues) to your
> boot options.  If this still doesn't work, I'd be interested in seeing a kernel
> log with the above two options *and* drm.debug=1.

I've enabled the 3 aforementioned options (which all give a "unkown boot option x : ignore"-message by the way), but I'm not seeing any progress.

I will attach my 'Xorg.0.log' and 'messages' (I assume you mean this file by kernel-log?)
Comment 20 A. Lok 2009-06-30 15:35:26 EDT
Created attachment 350012 [details]
Xorg.0.log
Comment 21 A. Lok 2009-06-30 15:36:07 EDT
Created attachment 350013 [details]
/var/log/messages
Comment 22 Ben Skeggs 2009-06-30 18:04:19 EDT
Ah, kms didn't get enabled, you misspelled nouveau.modeset=1 as noveau.modeset=1 :)

Btw, you might want to grab the -206 kernel from http://koji.fedoraproject.org/koji/buildinfo?buildID=112238 which has some additional fixes.
Comment 23 A. Lok 2009-07-01 13:10:25 EDT
Created attachment 350153 [details]
Xorg.0.log

Oops, sorry about that. Here is a corrected log file. (also with updated -206 kernel) It still doesn't work, and I've got to reboot manually, but there is another error-message in Xorg.0.log.
Comment 24 A. Lok 2009-07-01 13:12:33 EDT
Created attachment 350154 [details]
/var/log/messages
Comment 25 Ben Skeggs 2009-08-23 20:58:02 EDT
OK, is there any chance of trying rawhide?  The only potential issues I can see in your log file have been fixed there.  The kernel modesetting support in rawhide is looking very promising, I don't currently know of any general failure cases with the current code so it's definitely worth a look.
Comment 26 A. Lok 2009-08-28 16:00:47 EDT
(In reply to comment #25)
> OK, is there any chance of trying rawhide?  The only potential issues I can see
> in your log file have been fixed there.  The kernel modesetting support in
> rawhide is looking very promising, I don't currently know of any general
> failure cases with the current code so it's definitely worth a look.  

Sorry for the late reply, but I didn't have a rawhide installation at hand on this pc. I'm writing this comment, from within X, from a Fedora 12 aplha live-cd (x86-64).

As far as I see, I can't reproduce the bug anymore. Which is good :) What isn't good is that I'm now running into what seems bug #172475 ... :(

Well atleast my main screen is working.
Comment 27 Vedran Miletić 2009-10-15 15:36:25 EDT
Closing per comment #26.

Note You need to log in before you can comment on or make changes to this bug.