Bug 49554 - Nautilus refuses to allow umount
Nautilus refuses to allow umount
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-20 14:33 EDT by Steve Taylor
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-20 15:58:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Taylor 2001-07-20 14:33:54 EDT
Description of Problem:

If you have nautilus running, ie the default gnome configuration and pull
up a terminal and mount an nfs share and decide to umount it you will not
be able to if you have actually cd'ed into it. This happens even after you
have left the directory, evidentally nautilus is detected that your in
there and is using it.


How Reproducible:


Steps to Reproduce:
1. login into gnome with nautilus running
2. mount an nfs share
3. try to umount it after browsing in it.

Actual Results:

umount wont work because it is busy

Expected Results:

it should allow umounting

Additional Information:
	

[root@chatak root]# cd /mnt
[root@chatak mnt]# ls
cdrom  cdrom1  floppy  pork  rhs
[root@chatak mnt]# mount -t nfs porkchop:/mnt/redhat/ pork/
[root@chatak mnt]# cd pork/
[root@chatak pork]# ls
beehive  cvsweb      dist    glen  old-comps   redhat     slocate.db  touchme
broken   depends     errata  -i    prospector  rel-eng    spec2k
comps    dev_errata  est     msw   qa          sample.ks  test
[root@chatak pork]# cd errata/
[root@chatak errata]# ls
approve.cgi       globals.pl       postrequest.cgi         showrequest.cgi
backups           images           previewerrata.cgi       signrpm
CGI.pl            index.cgi        previewerrata.cgi.back  statusRHNerrata.cgi
conf              lib              processrequest.cgi      templates
core              listerrata.cgi   pusherrata2.cgi         tmp
CVS               listrequest.cgi  pusherrata.cgi          undupe_rpms.pl
data              logout.cgi       pusherrata.cgi.back     xmlrpc.cgi
defparams.pl      mailerrata.cgi   pushrhnlive.cgi         xmlrpc.cgi.back
doeditparams.cgi  mail.pl          pushrhnqa.cgi           xmlrpc_support.cgi
editparams.cgi    newerrata.cgi    redhat.key
errata_html       newrequest.cgi   showactivity.cgi
generrata.cgi     oracle           showerrata.cgi
[root@chatak errata]# cd /mnt
[root@chatak mnt]# umount pork
umount: /mnt/pork: device is busy
[root@chatak mnt]# lsof |grep pork
nautilus  21028 root   21r   DIR       0,10   24576   17252651
/mnt/pork/test/qa0713.0/ia64-disc3/SRPMS (porkchop:/mnt/redhat/)
nautilus  21052 root   21r   DIR       0,10   24576   17252651
/mnt/pork/test/qa0713.0/ia64-disc3/SRPMS (porkchop:/mnt/redhat/)
nautilus  21053 root   21r   DIR       0,10   24576   17252651
/mnt/pork/test/qa0713.0/ia64-disc3/SRPMS (porkchop:/mnt/redhat/)
nautilus  21054 root   21r   DIR       0,10   24576   17252651
/mnt/pork/test/qa0713.0/ia64-disc3/SRPMS (porkchop:/mnt/redhat/)
nautilus  21055 root   21r   DIR       0,10   24576   17252651
/mnt/pork/test/qa0713.0/ia64-disc3/SRPMS (porkchop:/mnt/redhat/)
[root@chatak mnt]#
Comment 1 Havoc Pennington 2001-07-20 15:11:36 EDT
What happens if you wait a few minutes and try the lsof again?
Comment 2 Glen Foster 2001-07-20 15:58:48 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 3 Havoc Pennington 2001-07-25 18:06:25 EDT
This was the search-for-trash misfeature, now removed.

Note You need to log in before you can comment on or make changes to this bug.