Bug 495560 - systemtap needs trace headers in kernel-devel to let traceprobes work
systemtap needs trace headers in kernel-devel to let traceprobes work
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
Development
All Linux
low Severity medium
: ---
: ---
Assigned To: Clark Williams
David Sommerseth
:
Depends On: 494950
Blocks: 329781
  Show dependency treegraph
 
Reported: 2009-04-13 15:55 EDT by Arnaldo Carvalho de Melo
Modified: 2016-05-22 19:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 494950
Environment:
Last Closed: 2011-09-28 12:44:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaldo Carvalho de Melo 2009-04-13 15:55:20 EDT
+++ This bug was initially created as a clone of Bug #494950 +++

Created an attachment (id=338784)
patch to add trace subdir to kernel-devel package

Description of problem:
AS part of my writing a script to emulate dropwatch via systemtap, I noted that I was not able to use kernel.trace probes or the stap -L option to list available probes.  stap always returned a NULL search result (indicating no tracepoints available).  The problem turns out to be that the kernel-devel package fails to include the include/trace subdirectory, so stap can't find any included probes.  We need to include this to allow systemtap to properly use tracepoints in 5.4



How reproducible:
Always

Steps to Reproduce:
1. run stap -L 'kernel.trace("*")'

  
Actual results:
semantic error: no match while resolving probe point kernel.trace("*")

Expected results:
list of available tracepoints in the kernel

Additional info:

--- Additional comment from pm-rhel@redhat.com on 2009-04-08 15:39:12 EDT ---

This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 1 Frank Ch. Eigler 2011-09-28 12:44:56 EDT
The stap code related to kernel tracepoints has learned to find tracepoint headers inside the source tree also.  It's not perfect, but is another way forward.

Note You need to log in before you can comment on or make changes to this bug.