This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 495582 - anaconda exception on rawhide snap1 (kde live), custom partitioning image
anaconda exception on rawhide snap1 (kde live), custom partitioning image
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:9132a5eda2b67b9d9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 16:44 EDT by MartinG
Modified: 2009-04-23 15:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 15:44:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (232.74 KB, text/plain)
2009-04-13 16:44 EDT, MartinG
no flags Details
Attached traceback automatically from anaconda. (106.70 KB, text/plain)
2009-04-23 08:48 EDT, Tim Lauridsen
no flags Details

  None (edit)
Description MartinG 2009-04-13 16:44:34 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 384, in lvresize
    raise LVMError("lvresize failed for %s" % lv_name)
  File "/usr/lib/anaconda/storage/devices.py", line 2024, in resize
    lvm.lvresize(self.vg.name, self._name, self.size)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 242, in execute
    self.device.resize(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 658, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 229, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
LVMError: lvresize failed for home
Comment 1 MartinG 2009-04-13 16:44:42 EDT
Created attachment 339377 [details]
Attached traceback automatically from anaconda.
Comment 2 MartinG 2009-04-13 16:48:18 EDT
So, this happened when I tried to create a customized partitioning table from anaconda (Fedora-11-Snap1-x86_64-Live-KDE), as I wanted to keep my /home.
I do have an jfs partition on the same drive, but left it without a mounting point (as it was grayed out anyway).
Comment 3 MartinG 2009-04-13 16:52:32 EDT
OMG: "lvresize failed for home" - did anaconda try to touch my /home partition anyway? I certainly did *not* set /home to be changed/formatted.
Comment 4 Chris Lumens 2009-04-13 17:04:09 EDT
Looks like it tried to resize home to the exact same size.  What choices did you make in the customized partition setup?  I imagine it would try to resize home if it needed to make some space for another volume that you wanted to grow.
Comment 5 MartinG 2009-04-13 17:16:00 EDT
I tried to map the exact same layout I had from a previous install, and did not change/resize any of the volumes. I mapped "swap" -> "swap" (reformat), "/" -> "/" (chose ext4, reformat), and set mounting point of /home to /home. I also set mounting point of  "/boot" to "/boot". I have one more logical volume named "media" that I left without any mountingpoint, as it is formatted jfs, and jfsutils was not present.

I didn't explicitly resize anything. Could it be due to rounding of numbers?

Btw. on my second boot I saw I/O errors from the cdrom during boot, just so you know in case that changes things. Will try new media now.
Comment 6 Tim Lauridsen 2009-04-23 08:48:36 EDT
Created attachment 340934 [details]
Attached traceback automatically from anaconda.
Comment 7 Tim Lauridsen 2009-04-23 08:56:06 EDT
i got this when trying to install F11-Snap1 on same partitions as my current installation.

/sda1 /boot -> /boot (format, ext3)

/sda2 LVM pv (VolGroup00)
/sdb1 LVM pv (VolGroup00)

/LogVol00 / -> / (format, ext4)

/LogVol01 Swap

/LogVol02 /home -> /home (no format)
Comment 8 Tim Lauridsen 2009-04-23 09:38:10 EDT
I tried to delete my /boot (using gparted) and my current / using (system-config-lvm) booted at restarted the livecd and tried again and created / and /boot in the freespace, but i got at traceback in lvresize again.

Got the latest boot.iso (22/4) and it seem to solve the issue. i was able to create a new /boot and a new / and install the system with Rawhide.
Comment 9 Chris Lumens 2009-04-23 15:44:04 EDT
Thanks for retesting.

Note You need to log in before you can comment on or make changes to this bug.