Bug 495609 - OpenOffice.org Impress crashes while opening PowerPoint 2007 (.pptx) file with embedded WAV audio.
OpenOffice.org Impress crashes while opening PowerPoint 2007 (.pptx) file wit...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 22:46 EDT by Gideon Mayhak
Modified: 2009-04-22 21:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 21:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error from Impress crash (11.74 KB, text/plain)
2009-04-13 22:46 EDT, Gideon Mayhak
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 101074 None None None Never

  None (edit)
Description Gideon Mayhak 2009-04-13 22:46:34 EDT
Created attachment 339408 [details]
Error from Impress crash

Description of problem:
When I try to load the following .pptx file, Impress crashes with the attached error message.

http://www.t-tartdirections.com/gideon/Final/Final.pptx - Final presentation for a PP 2007 class from a year ago; I just wanted to see if it would open with the latest Impress.

Version-Release number of selected component (if applicable):
openoffice.org-impress-3.1.0-9.2.fc11.x86_64

How reproducible:
Everytime (tried twice).

Steps to Reproduce:
1. Download http://www.t-tartdirections.com/gideon/Final/Final.pptx
2. Double-click or open from within Impress
3. Copy/paste crash results into text file and create bug report
  
Actual results:
Crash (big surprise with an OOXML file, right?).

Expected results:
Though I wasn't expecting much, I was kind of hoping it might actually open.  It's nothing special, but I'm sort of proud of that presentation.  I got an A ;-).

Additional info:
This file has a WAV audio file inside it.  There are also several images.  I'm sure I used some proprietary MS fonts during its creation.  It was made with PP 2007 for a PP 2007 class, so I probably just left the fonts as default for the most part (though I honestly don't remember).
Comment 1 Caolan McNamara 2009-04-14 06:49:25 EDT
Crash on background import. Fix now filed upstream as http://qa.openoffice.org/issues/show_bug.cgi?id=101074. Will be in >= fedora 3.1.0-9.3
Comment 2 Gideon Mayhak 2009-04-22 21:10:43 EDT
The file opens without a crash now.  Thanks!  It looks like crap, but I won't expect you to fix Microsoft's broken format ;-).

Note You need to log in before you can comment on or make changes to this bug.