Bug 495632 - Konqueror needs two more path for nspluginwrapper, flash
Konqueror needs two more path for nspluginwrapper, flash
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 02:12 EDT by Thomas Janssen
Modified: 2009-05-18 06:04 EDT (History)
6 users (show)

See Also:
Fixed In Version: 4.2-5.20090414
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 06:04:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Janssen 2009-04-14 02:12:38 EDT
Description of problem:
Konqueror not able to use 32bit plugins like flash-plugin (32bit).
If you run about:plugins in konqueror it's almost empty, not showing for example the flash-plugin.

It needs the following path added:
/usr/lib/mozilla/plugins-wrapped/
/usr/lib64/mozilla/plugins-wrapped/

If you run then nspluginscan (needed after you added the two path) The about:plugins is filled as expected.

It still is not working perfect. Got no youtube videos (just a grey box), but thats a different thing i have to fiddle with.

Version-Release number of selected component (if applicable):
kdebase-4.2.1-2.fc10.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thomas Janssen 2009-04-14 04:27:15 EDT
Ok, sorry, after fiddling around to get it completely working i did a strace on konqueror and www.wetter.de and i got:

http://fpaste.org/paste/9030

If it works for others i will be glad. Will fiddle a bit more.
Comment 2 Rex Dieter 2009-04-14 10:58:34 EDT
Looks like we had this set in *2* places, via a patch to kdebase and in kde-settings, and the latter takes precedence (and was wrong).  kde-setting is fixed in upstream svn(fedorahosted) now.

For posterity, we should probably only set this in one place, not 2.
Comment 3 Rex Dieter 2009-04-17 14:31:48 EDT
Interestingly, the code defaults seem to take preference over those in kde-settings if one presses the "defaults" button in the konq plugin/prefs page.

With that in mind, not sure if it's worth modifying kde-settings for < F-11.  anyone else able to confirm/deny, or offer opinion?
Comment 4 Lukáš Tinkl 2009-05-18 06:04:14 EDT
Fixed in kde-settings 4.2-5.20090414

Note You need to log in before you can comment on or make changes to this bug.