Bug 495672 - Cannot print to Direct to CD\DVD
Summary: Cannot print to Direct to CD\DVD
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 11
Hardware: i586
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-14 10:59 UTC by Frank Murphy
Modified: 2009-09-01 10:02 UTC (History)
2 users (show)

Fixed In Version: 3.9.8-12.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-01 10:02:24 UTC


Attachments (Terms of Use)
CD Pic (39.08 KB, image/png)
2009-04-14 11:02 UTC, Frank Murphy
no flags Details
Troubleshhot.txt (76.12 KB, text/plain)
2009-04-14 11:35 UTC, Frank Murphy
no flags Details
Meessage snip (1.49 KB, text/plain)
2009-04-14 12:38 UTC, Frank Murphy
no flags Details
HP-Check Log (13.43 KB, text/plain)
2009-04-14 17:50 UTC, Frank Murphy
no flags Details
scan of good DVD print (168.38 KB, image/png)
2009-08-28 18:45 UTC, Tom Horsley
no flags Details
and here's what the hplip-3.9.8-11 printout looks like (142.96 KB, image/png)
2009-08-28 18:49 UTC, Tom Horsley
no flags Details

Description Frank Murphy 2009-04-14 10:59:30 UTC
Description of problem:
Cannot print to Direct to CD\DVD

Version-Release number of selected component (if applicable):
gimp-2.6.6-2.fc11.i586
hplip-3.9.2-4.fc11.i586
hplip-gui-3.9.2-4.fc11.i586
hpijs-3.9.2-4.fc11.i586
cups-1.4-0.b2.13.fc11.i586
foomatic-4.0.0-2.fc11.i586

HP Photosmart D5460
How reproducible: Always


Steps to Reproduce:
1. Load Media
2. Change HPlip-GUI settings to "general > CD\DVD"
3. Try print from Gimp 2.6.6 with printer set to CD\DVD
  
Actual results: Just sits there pending, and lcd on printer says close CD-DVD tray


Expected results:Print to Disc


Additional info: If you can give me some pointers what to debug, I'll give it a lash.

Comment 1 Frank Murphy 2009-04-14 11:02:01 UTC
Created attachment 339460 [details]
CD Pic

Comment 2 Tim Waugh 2009-04-14 11:09:56 UTC
Please try using the printing troubleshooter, System->Administration->Printing frm the main menu, then Help->Troubleshoot.  When it asks you to print a test page, print as normal from GIMP.

You should end up with a troubleshoot.txt file to attach here.

Comment 3 Frank Murphy 2009-04-14 11:25:44 UTC
(In reply to comment #2)
> Please try using the printing troubleshooter, System->Administration->Printing
> frm the main menu, then Help->Troubleshoot.  When it asks you to print a test
> page, print as normal from GIMP.
> 

When I get this far, do I print a normal A4 page.
or try print to media, which the printer lcd complains about?

> You should end up with a troubleshoot.txt file to attach here.

Comment 4 Frank Murphy 2009-04-14 11:35:13 UTC
Created attachment 339464 [details]
Troubleshhot.txt

This is from trying to print to CD.

Comment 5 Tim Waugh 2009-04-14 12:01:59 UTC
Thanks.  Can you take a look in /var/log/messages?  There might be messages from hplip in there.

Comment 6 Frank Murphy 2009-04-14 12:32:56 UTC
Nothing specific with hplip.
Rebooted, started to try print ran dmesg|tail as below:

dmesg | tail
ip6_tables: (C) 2000-2006 Netfilter Core Team
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
eth0:  setting full-duplex.
eth0: no IPv6 routers present
fuse init (API version 7.11)
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
imsettings-xfce[2549]: segfault at c ip 032dab91 sp bfe28230 error 4 in libgconf-2.so.4.1.5[32ba000+34000]
usblp0: removed

Whether the usblp0: removed has anything to do with it.

If I close CD tray, as printer lcd requests, it prints the image to A4 sheet.

Comment 7 Frank Murphy 2009-04-14 12:38:33 UTC
Created attachment 339478 [details]
Meessage snip

Comment 8 Frank Murphy 2009-04-14 17:44:46 UTC
Found this same proplem, but Ubuntu:
https://answers.launchpad.net/hplip/+question/63943

Comment 9 Frank Murphy 2009-04-14 17:50:09 UTC
Created attachment 339531 [details]
HP-Check Log

Comment 10 Frank Murphy 2009-04-19 09:25:46 UTC
I checked against an F10 box using:
hplip-gui-2.8.7-3.fc10.i386
hplip-2.8.7-3.fc10.i386
hplip-libs-2.8.7-3.fc10.i386
hpijs-2.8.7-3.fc10.i386
hal-cups-utils-0.6.19-1.fc10.i386
cups-1.3.9-8.fc10.i386
cupsddk-drivers-1.2.3-5.fc10.i386
cups-libs-1.3.9-8.fc10.i386

and it does print to cd\dvd,
so am guessing some regression crept into 
hplip-3.9.2-4.fc11.i586

Question: Can I rebuild the F10-src.rpm  verion against the Rawhide\F11 box?

Comment 11 Bug Zapper 2009-06-09 13:47:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 12 Tom Horsley 2009-06-14 15:10:58 UTC
I just added some info to the launchpad issue:

https://answers.launchpad.net/hplip/+question/63943

My experiments with fedora 11 and forcing installs of f10 packages
reveal that the bug seems to lie in the hpijs package, not hplip.

Comment 13 Tom Horsley 2009-06-15 23:45:21 UTC
I just tried one more experiment. I put back the fedora 11 3.9.2 versions
of hplip and hpijs, then I erased hpijs and installed the f10 hpijs-2.8.12
version, and I can print to DVDs correctly with just the old hpijs
installed, everything else is the normal fedora 11 version. So maybe
this bug should move to hpijs?

Comment 14 Tom Horsley 2009-06-18 02:18:30 UTC
I see there is a hplip 3.9.6 just released today on sourceforge which has
a (oh joy) complete replacement for hplip they are calling hpcups.
That's bound to be backward compatible with all the nuances they've
built into hplip over the years, right? :-).

Anyway, maybe it fixes this problem?

Comment 15 Tom Horsley 2009-06-21 14:07:08 UTC
Forgetting 3.9.6 for the moment (which I image is a lot of work), there
was a patch posted in the hplip bugs which seems to work for the current
version of fedora 11 hplip. Here's the procedure I followed to get a working
/usr/bin/hpijs installed:

Bug is: https://bugs.launchpad.net/hplip/+bug/380858

Patch is: http://launchpadlibrarian.net/28140718/set-media-type.diff

I stashed it in /zooty/downloads/set-media-type.diff

Made a nice clean rpmbuild environment in /zooty/build/rpmbuild

rpm -ihv /zooty/downloads/hplip-3.9.2-4.fc11.src.rpm
cd SPECS/
rpmbuild -bp hplip.spec
cd ../BUILD/hplip-3.9.2/
patch -p0 < /zooty/downloads/set-media-type.diff
cd -
rpmbuild --short-circuit -bc hplip.spec
sudo cp ../BUILD/hplip-3.9.2/.libs/hpijs /usr/bin/hpijs-patched
cd /usr/bin
sudo ln hpijs hpijs.f11
sudo rm hpijs
sudo ln hpijs-patched hpijs

After this I can print DVDs again! Any chance we could get that patch
into fedora 11?

Comment 16 Fedora Update System 2009-06-24 09:53:20 UTC
hplip-3.9.2-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/hplip-3.9.2-5.fc11

Comment 17 Fedora Update System 2009-06-27 02:42:12 UTC
hplip-3.9.2-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 18 Fedora Update System 2009-07-29 21:29:01 UTC
hplip-3.9.6b-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 19 Fedora Update System 2009-08-05 00:29:19 UTC
hplip-3.9.6b-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 20 Fedora Update System 2009-08-07 04:58:36 UTC
hplip-3.9.8-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 21 Fedora Update System 2009-08-15 21:42:25 UTC
hplip-3.9.8-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 22 Fedora Update System 2009-08-19 23:17:32 UTC
hplip-3.9.8-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 23 Fedora Update System 2009-08-25 22:13:17 UTC
hplip-3.9.8-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 24 Fedora Update System 2009-08-27 02:10:30 UTC
hplip-3.9.8-10.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 25 Tom Horsley 2009-08-28 18:40:24 UTC
I've got a boot partition installed with fedora 12 alpha which has
hplip-3.9.8-11.fc12.x86_64 installed, so I figured I'd try my DVD
printing program out and see if it works. The answer is, unfortunately, NO.

Instead of printing anything that looks like it might be a DVD image, it
seems to have scaled the image to print on (perhaps) an 8.5x11 page, then
just printed the part of that which intersects the actual DVD media.

The program I'm using to print can be found at:

http://home.att.net/~Tom.Horsley/kewpie/kewpie.html

I'll attach scans of a printout from a version of hplip where it worked
fine, and a scan of the one that didn't work under 3.9.8-11.

I not only ran Print Setup and set the tray and media to 120mm DVD,
but I also configured the printer to make those the defaults, all
to no avail :-).

Comment 26 Tom Horsley 2009-08-28 18:45:05 UTC
Created attachment 359105 [details]
scan of good DVD print

This is a printout of a CD I made when hplip was working correctly.

Comment 27 Tom Horsley 2009-08-28 18:49:05 UTC
Created attachment 359106 [details]
and here's what the hplip-3.9.8-11 printout looks like

This uses the same program to print the same image file to the same printer.
As you can see, the results are not the same.

Comment 28 Fedora Update System 2009-08-28 21:57:12 UTC
hplip-3.9.8-12.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959

Comment 29 Tim Waugh 2009-08-29 10:59:47 UTC
Will investigate this next week.

Comment 30 Fedora Update System 2009-08-31 23:29:42 UTC
hplip-3.9.8-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 31 Tim Waugh 2009-09-01 08:07:18 UTC
(3.9.8-12.fc11 was automatically pushed in the mean time, which is what comment #30 is about.)

Comment 32 Tom Horsley 2009-09-01 09:36:55 UTC
Actually, something fixed it in rawhide. The 3.9.8-14 update is back to printing
DVDs mostly correctly now. (If only I could figure out how to get it to stop
cutting off the top 2 millimeters, it would be perfect, but that is no doubt
a separate problem).

Comment 33 Tim Waugh 2009-09-01 10:02:24 UTC
OK, great, glad this one is fixed now.  Thanks for letting me know.


Note You need to log in before you can comment on or make changes to this bug.