Bug 495675 - Kaffeine crashes when trying to watch a DVB channel with F11 Snap1
Kaffeine crashes when trying to watch a DVB channel with F11 Snap1
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kaffeine (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 07:11 EDT by Juhani Jaakola
Modified: 2009-05-26 16:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 16:39:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juhani Jaakola 2009-04-14 07:11:29 EDT
Description of problem:
I started the F11 Snap1 Live CD (the Gnome version) and installed Kaffeine and some plugins:

# rpm -Uhv http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-rawhide.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-rawhide.noarch.rpm
# yum install kaffeine xine-lib xine-lib-extras xine-lib-extras-freeworld

Then I can started Kaffeine and scanned DVB channels. But when I try to watch a DVB channel Kaffeine crashes:

$ kaffeine
mkdir: Owner of /tmp/.ICE-unix should be set to root
kbuildsycoca running...
/dev/dvb/adapter0/frontend0 : opened ( TerraTec/qanu USB2.0 Highspeed DVB-T Receiver )
0 EPG plugins loaded for device 0:0.
Tuning to: YLE FST5 / autocount: 0
DvbCam::probe(): /dev/dvb/adapter0/ca0: : No such file or directory
Using DVB device 0:0 "TerraTec/qanu USB2.0 Highspeed DVB-T Receiver"
tuning DVB-T to 610000000 Hz
inv:2 bw:0 fecH:2 fecL:9 mod:3 tm:1 gi:2 hier:0
.. LOCKED.
NOUT: 1
dvbEvents 0:0 started
Tuning delay: 220 ms
KCrash: Application 'kaffeine' crashing...
KCrash cannot reach kdeinit, launching directly.

I installed the additional Xine plugins because yesterday when I installed Kaffeine without Xine plugins I could scan DVB channels and see EPG but no sound nor video!

Here is another way of crashing Kaffeine:
- Start Kaffeine
- Choose from the menu Settings -> xine Engine Parameters

Version-Release number of selected component (if applicable):
kaffeine-0.8.7-7.fc11.i586
xine-lib-1.1.16.3-2.fc11.i586
xine-lib-extras-1.1.16.3-2.fc11.i586
xine-lib-extras-freeworld-1.1.16.3-1.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Boot with F11 Snap1 Live CD (Gnome version)
2. Install Kaffeine and plugins (see above)
3. Start Kaffeine and tune DVB channels
4. Try to watch a channel
  
Actual results:
Kaffeine crashes

Expected results:
The selected channel is displayed

Additional info:
Comment 1 Juhani Jaakola 2009-04-29 09:50:24 EDT
Same problem with the F11 Preview i686 Live CD (the Gnome version, not KDE version). I installed the same programs as before, scanned the channels and started Kaffeine. When I try to watch a channel, Kaffeine crashes:

$ kaffeine
mkdir: Owner of /tmp/.ICE-unix should be set to root
kbuildsycoca running...
/dev/dvb/adapter0/frontend0 : opened ( TerraTec/qanu USB2.0 Highspeed DVB-T Receiver )
0 EPG plugins loaded for device 0:0.
Loaded epg data : 4175 events (37 msecs)
[liveuser@localhost /]$ Tuning to: MTV3 / autocount: 0
DvbCam::probe(): /dev/dvb/adapter0/ca0: : No such file or directory
Using DVB device 0:0 "TerraTec/qanu USB2.0 Highspeed DVB-T Receiver"
tuning DVB-T to 666000000 Hz
inv:2 bw:0 fecH:2 fecL:9 mod:3 tm:1 gi:2 hier:0
. LOCKED.
NOUT: 1
dvbEvents 0:0 started
Tuning delay: 148 ms
KCrash: Application 'kaffeine' crashing...
KCrash cannot reach kdeinit, launching directly.

If I install only keffeine and xine-libs, Kaffeine won't crash but there is no video nor sound!

Versions:

kernel-2.6.29.1-102.fc11.i586
kaffeine-0.8.7-7.fc11.i586
xine-lib-1.1.16.3-2.fc11.i586
xine-lib-extras-1.1.16.3-2.fc11.i586
xine-lib-extras-freeworld-1.1.16.3-1.fc11.i586
ffmpeg-libs-0.5-2.fc11.i586
Comment 2 Juhani Jaakola 2009-05-26 16:39:45 EDT
I have installed F11 to hard disk and updated latest packages. Now Kaffeine works fine! I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.