Bug 49569 - xscreensaver hangs with GL screensavers.
xscreensaver hangs with GL screensavers.
Status: CLOSED DUPLICATE of bug 73827
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-20 15:26 EDT by Kirk Morrow
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-13 14:23:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core file from shutdown after hang of cage screen saver. (11.57 MB, application/octet-stream)
2001-07-20 15:29 EDT, Kirk Morrow
no flags Details

  None (edit)
Description Kirk Morrow 2001-07-20 15:26:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
When running a GL screensaver xscreensaver will occasionally hang.

How reproducible:
Sometimes

Steps to Reproduce:
1. Using xscreensaver-demo, enable blanking, cycling, locking and power
management and activate GL screensavers.
2. Lock console in X.
3. Wait.
	

Actual Results:  After a while the screensaver will hang (motion on screen
stops), DPMS won't power down monitor ever, and keyboard activity is
ignored (can't get to virtual consoles or type password to unlock screen).

Expected Results:  Screensaver should keep running and typing password
should unlock screen.

Additional info:

Although the keyboard becomes useless, it is still possible to access the
machine from the network.  Issuing init 3, does nothing.  The only thing
that I've found works is rebooting the machine.  A core file is created by
the shutdown.

So far I've seen hangs with Rubik, Planetary Gears, Cage and Atlantis.

The machine is a Pentium II/266 with a Voodoo3 PCI card.

I'm attaching the core file from a crash with Cage.
Comment 1 Kirk Morrow 2001-07-20 15:29:53 EDT
Created attachment 24347 [details]
Core file from shutdown after hang of cage screen saver.
Comment 2 Bill Nottingham 2002-01-24 00:51:48 EST
That indicates the X server is hanging.
Comment 3 Mike A. Harris 2002-02-03 09:15:11 EST
I need you to attach your X server log, your X config file, your
/var/log messages file as individual file attachments using the
link below.

TIA
Comment 4 Mike A. Harris 2002-03-14 12:36:43 EST
Please provide the requested information.
Comment 5 Kirk Morrow 2002-03-14 22:27:48 EST
When I get the time to intentionally let my system crash, I'll get these for 
you.  However, right now I really need this system up and running to do my job.
Comment 6 Mike A. Harris 2002-03-15 01:22:51 EST
Ok, when you get a chance to provide the necessary debugging information,
please reopen the report with the files attached below.

Thanks.
Comment 7 Kirk Morrow 2002-06-07 11:29:56 EDT
I've had this hang occur again.  The system is now a Pentium III/533 with the 
same Voodoo 3 card.  I've checked /var/log/messages and /var/log/XFree86.0.log 
but neither seem to provide any useful information.  Also, I'm now unable to 
locate the core file.  Please give me a list of the exact files including their 
paths just in case I encounter this hang again.
Comment 8 Kirk Morrow 2002-06-13 14:22:37 EDT
And it crashed again...  What $path/$files do you need?
Comment 9 Kirk Morrow 2002-06-13 14:22:55 EDT
And it crashed again...  What $path/$files do you need?
Comment 10 Mike A. Harris 2002-09-11 14:33:24 EDT

*** This bug has been marked as a duplicate of 73827 ***

Note You need to log in before you can comment on or make changes to this bug.