Bug 495738 - Fedora 11 beta - new GDM greeter does not allow to shutdown properly
Fedora 11 beta - new GDM greeter does not allow to shutdown properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-04-14 10:58 EDT by stef
Modified: 2015-01-14 18:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 13:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description stef 2009-04-14 10:58:16 EDT
Description of problem:
When on the GDM greeter (meaning no user is logged in), pressing the computer Power button doesn't start the shutdown procedure, it raises a question box (unlike Fedora versions until at least 8), but when selecting "Shut Down" an error box raises :
"A program is still running : gdm-simple-greeter.desktop - Not responding..."

We can force the shutdown but the greeter definitely shouldn't lock here

Version-Release number of selected component (if applicable):
Fedora 11 beta

How reproducible:
always

Steps to Reproduce:
1.be on the GDM greeter, noone logged in
2.press the Power button to shut down the computer
3.select the "Shut Down" choice
  
Actual results:
lock on gdm-simple-greeter.desktop application

Expected results:
computer Shut Down

Additional info:
Comment 1 Matthias Runge 2009-04-15 05:35:54 EDT
May be related:
Shutdown from Gnome does not work, either. 
1. Log in
2. Select restart from Gnome Menu
3. Wait (until someone sends an acpi switch off)
Comment 2 Matthias Clasen 2009-04-21 23:44:56 EDT
I have seen this at one point, but I can't reproduce it anymore now. Are you still seeing this ?
Comment 3 stef 2009-04-22 03:25:49 EDT
I just applied all the available updates to see it was fixed now.

Trouble still here.

Pressing the power button raises a windows with multiple answers, clicking on 'Shut Down' gives the locking windows instead of launching the shutdown procedure.
Comment 4 stef 2009-04-22 03:39:44 EDT
Interesting ...

Now I can't reproduce the problem only a few reboots from my previous comment #3.

The problem seems harder to track than it seems, and there was no new update in the packages.
Comment 5 Matthias Runge 2009-04-22 05:42:08 EDT
I did a number of tests (more than 2x pi) on a VirtualBox, trying to reproduce.  Sadly, I was unable to reproduce the problem (noone logged in, press shutdown and the box "gdm does not respond"). (cf. #1)

Trying to shut down a machine, when logged in, I was unable to reproduce the error, either. (cf. #2)
Comment 6 Michael Wagner 2009-04-23 05:37:04 EDT
Maybe <a href="https://bugzilla.redhat.com/show_bug.cgi?id=495738#c2">comment #2</a> is related to <a href="https://bugzilla.redhat.com/show_bug.cgi?id=495191">#495191</a>. Although it happens less frequent lately, I can reproduce it almost every time, if I try to restart immediately after logging in. This didn't occur with gnome-session 2.26.0.

Greetings,

Michael
Comment 7 Michael Wagner 2009-04-23 08:24:55 EDT
Sorry, it should be https://bugzilla.redhat.com/show_bug.cgi?id=495738#c1
Comment 8 Matthias Clasen 2009-04-24 19:31:05 EDT
Ok, I finally found what you mean here. 

Pressing the power button on your laptop  behaves differently from pressing the shutdown button on the greeter. The former does indeed bring up the gnome-session shutdown dialog, and after that the inhibit dialog.
Comment 9 Matthias Clasen 2009-04-24 21:13:12 EDT
This is fixed in gdm-2.26.1-4.fc11
Comment 10 Michael Monreal 2009-04-28 15:50:35 EDT
(In reply to comment #1)
> May be related:
> Shutdown from Gnome does not work, either. 
> 1. Log in
> 2. Select restart from Gnome Menu
> 3. Wait (until someone sends an acpi switch off)  

Hmm... I have run into this a number of times even _after_ updating to the latest GDM build. When shutting down, the process seems to hang at the terminal until I press the power button, at which time the "shutting down xyz   [done]" appear and the box powers off. I mostly shut down from GNOME.
Comment 11 stef 2009-04-29 04:52:39 EDT
Okay, problem evolved for me.

I can't reproduce the "A program is still running : gdm-simple-greeter.desktop - Not responding..." window problem.

BUT, now when I select Power Down I sometimes end on the X desktop with the background decoration, no window nor tool-bar, only the background with the mouse pointer and the system just sits here forever.

It does move on and shutdown when I press Power button again or do ctrl-alt-F[2-3-4-...] (not sure which action made it move really) but I have to do something actually
Comment 12 Michael Monreal 2009-04-29 06:42:03 EDT
(In reply to comment #11)
> I can't reproduce the "A program is still running : gdm-simple-greeter.desktop
> - Not responding..." window problem.
Yeah this is gone for quite some time.

> BUT, now when I select Power Down I sometimes end on the X desktop with the
> background decoration, no window nor tool-bar, only the background with the
> mouse pointer and the system just sits here forever.
I actually got that too once or twice, but what I reported in comment #10 happens more often to me...
Comment 13 stef 2009-04-29 07:03:14 EDT
(In reply to comment #12)
> I actually got that too once or twice, but what I reported in comment #10
> happens more often to me...  

Yup, same behavior here.

X closing, back to the console, "The system is going down for reboot NOW!" ... then nothing.

At this point pressing ctrl-alt-del makes it reboot for real but that's not what expected.
Comment 14 Michael Wagner 2009-05-02 03:49:27 EDT
The problems in comment #1 and comment #10 seem to be related to bug 495326. Patching /etc/event.d/rc? did the trick for me.
Comment 15 Michael Monreal 2009-05-02 11:10:24 EDT
(In reply to comment #14)
> The problems in comment #1 and comment #10 seem to be related to bug 495326.
> Patching /etc/event.d/rc? did the trick for me.  

I think you are totally right. After installing initscripts-8.95-1 I have yet to see any shutdown problems, nice.
Comment 16 Jesse Keating 2009-05-11 13:34:37 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.