Bug 495758 - Missing application/msword mime type hander leads to no automatic installation of Open Office for .doc files
Missing application/msword mime type hander leads to no automatic installatio...
Status: CLOSED DUPLICATE of bug 494817
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 13:15 EDT by Mads Kiilerich
Modified: 2009-04-23 18:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 06:50:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2009-04-14 13:15:27 EDT
Description of problem:

I had a .doc file on the desktop. When I doubleclicked it PackageKit recognized it as a Word file and offered me to install Koffice or AbiWord (or ClamAV which might be slightly confusing). It did not suggest installing open office. 

I would expect installation of Open Office for .doc files to be one of the primary user stories for http://fedoraproject.org/wiki/Features/AutoFontsAndMimeInstaller .


Version-Release number of selected component (if applicable):

PackageKit-0.4.6-2.fc11.i586
- which other packages are relevant?
Comment 1 Richard Hughes 2009-04-15 12:31:46 EDT
Looking at http://koji.fedoraproject.org/koji/rpminfo?rpmID=1161809:

mimehandler(application/vnd.ms-word.document.macroenabled.12)
mimehandler(application/vnd.ms-word.template.macroenabled.12)

When PackageKit is searching for: "application/msword"

The /usr/share/applications/openoffice.org-writer.desktop file has:

MimeType=application/vnd.oasis.opendocument.text;application/vnd.oasis.opendocument.text-template;application/vnd.oasis.opendocument.text-web;application/vnd.oasis.opendocument.text-master;application/vnd.sun.xml.writer;application/vnd.sun.xml.writer.template;application/vnd.sun.xml.writer.global;application/vnd.stardivision.writer;application/msword;application/vnd.ms-word;application/x-doc;application/rtf;text/rtf;application/vnd.wordperfect;application/wordperfect;application/vnd.openxmlformats-officedocument.wordprocessingml.document;application/vnd.ms-word.document.macroenabled.12;application/vnd.openxmlformats-officedocument.wordprocessingml.template;application/vnd.ms-word.template.macroenabled.12;

When abiword has:

MimeType=application/x-abiword;text/x-abiword;text/x-xml-abiword;text/plain;application/msword;application/rtf;application/vnd.plain;application/xhtml+xml;text/html;application/x-crossmark;application/docbook+xml;application/x-t602;application/vnd.oasis.opendocument.text;application/vnd.sun.xml.writer;application/vnd.stardivision.writer;text/vnd.wap.wml;application/wordperfect6;application/wordperfect5.1;application/x-mif;application/x-kword;application/x-mswrite;application/x-applix-word;application/vnd.wordperfect;

I think all that is needed is for openoffice.org-writer to have application/msword added to the mimetypes, and to be rebuilt in koji.
Comment 2 Caolan McNamara 2009-04-16 04:03:44 EDT
mimehandler(application/vnd.ms-word.document.macroenabled.12) and
mimehandler(application/vnd.ms-word.template.macroenabled.12)

are for the new msword xml-based .docx etc, file formats, don't let that confuse you wrt. to the older .doc formats. The line you pasted in from OOo already also includes application/msword for .the .doc format.

rpm -q --provides openoffice.org-writer|grep mimehandler
mimehandler(application/vnd.ms-word.document.macroenabled.12)  
mimehandler(application/vnd.ms-word.template.macroenabled.12)  
mimehandler(application/vnd.oasis.opendocument.text)  
mimehandler(application/vnd.oasis.opendocument.text-master)  
mimehandler(application/vnd.oasis.opendocument.text-template)  
mimehandler(application/vnd.oasis.opendocument.text-web)  
mimehandler(application/vnd.openxmlformats-officedocument.wordprocessingml.document)  
mimehandler(application/vnd.openxmlformats-officedocument.wordprocessingml.template)  
mimehandler(application/vnd.sun.xml.writer)  
mimehandler(application/vnd.sun.xml.writer.global)  
mimehandler(application/vnd.sun.xml.writer.template)  

so there's a *load* of mimetypes listed in the .desktop file which are missing, i.e. this entire set...

application/vnd.stardivision.writer;
application/msword;
application/vnd.ms-word;
application/x-doc;
application/rtf;
text/rtf;
application/vnd.wordperfect;
application/wordperfect;

which aren't listed in the provides mimehandler.

So where does that mimehandler list in the package come from ? built-into our rpm tooling somewhere or something that rpm calls to parse the .destop file
Comment 3 Caolan McNamara 2009-04-16 05:21:23 EDT
so...

rpm -ql openoffice.org-writer|grep usr\/share\/applications | /usr/lib/rpm/desktop-file.prov

mimehandler(application/vnd.oasis.opendocument.text)
mimehandler(application/vnd.oasis.opendocument.text-template)
mimehandler(application/vnd.oasis.opendocument.text-web)
mimehandler(application/vnd.oasis.opendocument.text-master)
mimehandler(application/vnd.sun.xml.writer)
mimehandler(application/vnd.sun.xml.writer.template)
mimehandler(application/vnd.sun.xml.writer.global)
mimehandler(application/vnd.stardivision.writer)
mimehandler(application/msword)
mimehandler(application/vnd.ms-word)
mimehandler(application/x-doc)
mimehandler(application/rtf)
mimehandler(text/rtf)
mimehandler(application/vnd.wordperfect)
mimehandler(application/wordperfect)
mimehandler(application/vnd.openxmlformats-officedocument.wordprocessingml.document)
mimehandler(application/vnd.ms-word.document.macroenabled.12)
mimehandler(application/vnd.openxmlformats-officedocument.wordprocessingml.template)
mimehandler(application/vnd.ms-word.template.macroenabled.12)

i.e. that list is good, but looking at the koji logs for the build I see...

Processing files: openoffice.org-writer-3.1.0-9.2.fc11.x86_64
Provides: mimehandler(application/vnd.ms-word.document.macroenabled.12) mimehandler(application/vnd.ms-word.template.macroenabled.12) mimehandler(application/vnd.oasis.opendocument.text) mimehandler(application/vnd.oasis.opendocument.text-master) mimehandler(application/vnd.oasis.opendocument.text-template) mimehandler(application/vnd.oasis.opendocument.text-web) mimehandler(application/vnd.openxmlformats-officedocument.wordprocessingml.document) mimehandler(application/vnd.openxmlformats-officedocument.wordprocessingml.template) mimehandler(application/vnd.sun.xml.writer) mimehandler(application/vnd.sun.xml.writer.global) mimehandler(application/vnd.sun.xml.writer.template)
Comment 4 Richard Hughes 2009-04-16 06:14:03 EDT
Panu, any ideas?
Comment 5 Panu Matilainen 2009-04-16 06:24:23 EDT
Probably a variant / dupe of bug 494817. What does "file /path/to/desktop/file" say on the files whose mime types are missing?
Comment 6 Caolan McNamara 2009-04-16 06:50:51 EDT
Yeah, "UTF-8 Unicode Pascal program text, with very long lines", I created a few more gotchas as well. I'll add them to the other issue.

The Polish comment using "program" is what tips us over the edge to become Pascal

*** This bug has been marked as a duplicate of bug 494817 ***
Comment 7 Caolan McNamara 2009-04-16 06:54:28 EDT
If anyone can reword

"Twórz i edytuj listy, raporty, dokumenty i strony www wykorzystując program Writer"

to not use "program" then I could stick that in as a quick-fix :-)

I guess program->programu would be bad grammar ?
Comment 8 Mads Kiilerich 2009-04-16 08:13:10 EDT
Perhaps an invisible unicode character could be inserted or an alternative utf-8 encoding used?
Comment 9 Caolan McNamara 2009-04-16 08:27:24 EDT
Yeah, I'll lamp in a temp fix of using U+00A0 NO-BREAK SPACE instead of U+0020 SPACE at the end of "program ", that's sufficient to dissuade file from calling it pascal source code for now
Comment 10 Mads Kiilerich 2009-04-23 18:49:46 EDT
I can confirm that it works now.

The list shown to the user is however quite confusing. Perhaps some packages could be fixed with either better description or by not being on the list at all. 

I suggest reviewing the list shown for the formats most often met by regular users. Something like .doc, .xls, .ppt, .docx, .xlsx, .pptx, .pdf, .zip.

But ... the user is probably not interested in all the applications that can handle that file type. She wants to know which application is recommended among those in the Fedora distribution. By its nature that must be a fedora-global package containing that meta information. It does not have to be perfect, but entries in this list should be listed the others.

Note You need to log in before you can comment on or make changes to this bug.