Bug 495761 - Esc in "Applications that can open this type of file" means "Install"
Esc in "Applications that can open this type of file" means "Install"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 13:23 EDT by Mads Kiilerich
Modified: 2009-06-25 05:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 05:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2009-04-14 13:23:58 EDT
Description of problem:

After clicking an unknown file in nautilis the window "Applications that can open this type of file" is shown. When I press Esc then it continues as if I had clicked Install. I would expect it to cancel this dialog/wizard.

(The dialog has a Close button - in this context Cancel would be more appropriate.)


Version-Release number of selected component (if applicable):

PackageKit-0.4.6-2.fc11.i586
Comment 1 Bug Zapper 2009-06-09 09:49:00 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Matthias Clasen 2009-06-11 13:23:53 EDT
I guess this is caused by gpk-helper-chooser.c reusing a dialog but treating it as a window. It probably needs to set up an action id for the buttons, at least.

Ideally, if you just want a window, don't use a dialog.
Or, if you want to use a dialog, use gtk_dialog_run or the response signal...
Comment 3 Richard Hughes 2009-06-25 05:54:29 EDT
commit fff4efac6fa0d8bdd64af97826586dd024fe0807
Author: Richard Hughes <richard@hughsie.com>
Date:   Thu Jun 25 10:53:15 2009 +0100

    Don't ignore the user pressing escape to dismiss a GpkHelperChooser

Note You need to log in before you can comment on or make changes to this bug.