Bug 495846 - pulseaudio suddenly crashed while using rhythmbox: snd_pcm_avail() returned a value that is exceptionally large: 4294951960 bytes (24347800 ms).
pulseaudio suddenly crashed while using rhythmbox: snd_pcm_avail() returned a...
Status: CLOSED DUPLICATE of bug 472339
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 00:50 EDT by Diego Escalante Urrelo
Modified: 2009-04-15 13:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 13:05:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Diego Escalante Urrelo 2009-04-15 00:50:38 EDT
Description of problem:
pulseaudio crashed suddenly, while listening to some music

Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-9.test8.fc11.i586

How reproducible:
Everytime I play music for a reasonable time (some 2 or 3 minutes)

Steps to Reproduce:
1. Opened rb/totem
2. Play music, wait 2~3 minutes into the song or songs
3. pulseaudio dies, UI reports connection missing/closed
  
Actual results:
music stops

Expected results:
music doesn't stop

Additional info:
Crash prints this:
N: alsa-sink.c: Increasing wakeup watermark to 40.00 ms
E: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294952316 bytes (24347802 ms).
E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
E: alsa-util.c: snd_pcm_dump():
E: alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0
E: alsa-util.c: Its setup is:
E: alsa-util.c:   stream       : PLAYBACK
E: alsa-util.c:   access       : MMAP_INTERLEAVED
E: alsa-util.c:   format       : S16_LE
E: alsa-util.c:   subformat    : STD
E: alsa-util.c:   channels     : 2
E: alsa-util.c:   rate         : 44100
E: alsa-util.c:   exact rate   : 44100 (44100/1)
E: alsa-util.c:   msbits       : 16
E: alsa-util.c:   buffer_size  : 16384
E: alsa-util.c:   period_size  : 16384
E: alsa-util.c:   period_time  : 371519
E: alsa-util.c:   tstamp_mode  : ENABLE
E: alsa-util.c:   period_step  : 1
E: alsa-util.c:   avail_min    : 16384
E: alsa-util.c:   period_event : 0
E: alsa-util.c:   start_threshold  : -1
E: alsa-util.c:   stop_threshold   : 1073741824
E: alsa-util.c:   silence_threshold: 0
E: alsa-util.c:   silence_size : 0
E: alsa-util.c:   boundary     : 1073741824
E: rtpoll.c: Assertion 'usec <= ((pa_usec_t) 1000000ULL)*60ULL*60ULL' failed at pulsecore/rtpoll.c:548, function pa_rtpoll_set_timer_relative(). Aborting.
Comment 1 Lennart Poettering 2009-04-15 13:05:11 EDT

*** This bug has been marked as a duplicate of bug 472339 ***

Note You need to log in before you can comment on or make changes to this bug.