Bug 495848 - traceback: setup failed - FormatSetupError
traceback: setup failed - FormatSetupError
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
anaconda_trace_hash:e2693689c6e7ff3c9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 00:53 EDT by Mike Wolf
Modified: 2009-04-21 05:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 05:53:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (90.50 KB, text/plain)
2009-04-15 00:53 EDT, Mike Wolf
no flags Details
Attached traceback automatically from anaconda. (80.97 KB, text/plain)
2009-04-15 18:33 EDT, Mike Wolf
no flags Details

  None (edit)
Description Mike Wolf 2009-04-15 00:53:32 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 271, in setup
    raise FormatSetupError("format has not been created")
  File "/usr/lib/anaconda/storage/devices.py", line 1424, in setup
    self.slave.format.setup()
  File "/usr/lib/anaconda/storage/devices.py", line 250, in setupParents
    parent.setup()
  File "/usr/lib/anaconda/storage/devices.py", line 1624, in setup
    self.setupParents()
  File "/usr/lib/anaconda/storage/devices.py", line 1925, in setup
    self.vg.setup()
  File "/usr/lib/anaconda/storage/devices.py", line 546, in minSize
    self.setup()
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 363, in createPreExistFSOptionSection
    reqlower = origrequest.minSize
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 491, in editLogicalVolume
    (row, self.fsoptionsDict) = createPreExistFSOptionSection(reallv, maintable, row, mountCombo, self.storage, ignorefs = ["software RAID", "physical volume (LVM)", "vfat"], luksdev=templuks)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 704, in editCurrentLogicalVolume
    self.editLogicalVolume(lv)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 735, in editLogicalVolumeCB
    self.editCurrentLogicalVolume()
FormatSetupError: format has not been created
Comment 1 Mike Wolf 2009-04-15 00:53:37 EDT
Created attachment 339626 [details]
Attached traceback automatically from anaconda.
Comment 2 Mike Wolf 2009-04-15 01:13:21 EDT
Error has occurred on both an Acer Aspire 3680 and Dell Dimension B110.  You have to install once, and then reinstall.  Encryption may also be a factor, but I haven't gotten to testing this without encryption to see for sure.

Reproducible: Always.

To recreate:

1.  Install Fedora 11 beta from DVD.  Change the default disk setup to the following:

Single Drive: /dev/sda
Size: 76317MB

Partitions:

/dev/sda1:  200MB, ext3, /boot
/dev/sda2:  45396MB, LVM (This is encrypted)
/dev/sda3:  30720MB, ext4, /home (This is encrypted)

On /dev/sda2 (which is encrypted), I have:

lv_root:  42420MB, ext4, /  (root)
lv_swap:  2972MB, swap

sda2 & sda3 are encrypted with the same passphrase.


2.  After a successful installation, start reinstall from DVD.

3.  Enter passphrase for encrypted drive and choose "This is a global passphrase".

4.  Choose "Create Custom layout" and click "Next"

5.  Select /dev/sda2 and click "Edit".

6.  Click the "Format as:" box, and choose "physical volume (LVM)".  The "Encrypt" checkbox should already be checked.  Leave it that way, and click "OK".

7.  Under the volume group, select "lv_root" then click "Edit".

8.  When the "Edit LVM Volume Group" window pops up, select "lv_root" and click "Edit".

9.  Crash!


Bug 495176 may be related to this one, as I was trying to figure out what EXACT actions were needed to cause that bug to appear when I discovered this one.  The tracebacks, however, indicate failures in different functions.
Comment 3 Mike Wolf 2009-04-15 18:33:43 EDT
Created attachment 339755 [details]
Attached traceback automatically from anaconda.
Comment 4 Mike Wolf 2009-04-15 18:47:52 EDT
Comment #3 is on Dell Optiplex GX270.  NOTE!  It isn't necessary to do all the extra disk setup on the initial install.  The only changes I made to the default layout was to encrypt the disk, and subtract 4MB from the swap partition, per the workaround listed for Bug 493575.  Everything from step #2 on down is the same.

My next test will be to try this with no encryption.
Comment 5 Mike Wolf 2009-04-15 19:53:27 EDT
Okay, if I don't use encryption during the initial install, I cannot replicate this bug on the reinstall.  When you get to step #5 (from Comment #2), you get a pop-up that says "You cannot edit this device:  This device is part of the LVM group 'vg_gx2701'."  So for some reason having the drives initially encrypted prevents this box from popping up.
Comment 8 Martin Sivák 2009-04-20 10:28:01 EDT
Mike, can you retest with rawhide nightly build please? We taught anaconda some rules about editing luks devices :) and it might have solved both this bug and #495176.
Comment 9 Mike Wolf 2009-04-20 19:08:52 EDT
I just tried the nightly rebuild for 4-20-2009.  This bug is fixed as of anaconda 11.5.0.46-1, thanks!
Comment 10 Martin Sivák 2009-04-21 05:53:58 EDT
Thanks for testing it Mike, I wish we had more reporters like you.

Note You need to log in before you can comment on or make changes to this bug.