Bug 495852 - mono-addins 0.4-6.20091702svn127062.1.fc11 upgrade fails (missing provides)
mono-addins 0.4-6.20091702svn127062.1.fc11 upgrade fails (missing provides)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tomboy (Show other bugs)
rawhide
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 01:47 EDT by Jeremy Huddleston
Modified: 2009-04-15 21:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 21:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Huddleston 2009-04-15 01:47:17 EDT
[jeremy@localhost ~]$ sudo yum upgrade mono-addins
Loaded plugins: refresh-packagekit
Setting up Upgrade Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package mono-addins.ppc 0:0.4-6.20091702svn127062.1.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================
 Package                   Arch              Version                                      Repository             Size
======================================================================================================================
Updating:
 mono-addins               ppc               0.4-6.20091702svn127062.1.fc11               rawhide               484 k

Transaction Summary
======================================================================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total size: 484 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
mono(Mono.Addins) is needed by (installed) tomboy-0.12.0-5.fc10.ppc
mono(Mono.Addins.Gui) is needed by (installed) tomboy-0.12.0-5.fc10.ppc
mono(Mono.Addins.Setup) is needed by (installed) tomboy-0.12.0-5.fc10.ppc
Comment 1 Paul F. Johnson 2009-04-15 02:59:45 EDT
This isn't a mono-addin problem. Tomboy needs to be rebuilt.
Comment 2 Jeremy Huddleston 2009-04-15 03:52:36 EDT
well then reassign it to tomboy rather than closing...
Comment 3 Matthias Clasen 2009-04-15 10:39:50 EDT
And its not a rawhide problem at all, from the looks of it...
Comment 4 Jeremy Huddleston 2009-04-15 16:23:01 EDT
Well it's happening on rawhide.  All my repos have been rawhide since I installed a "fresh" fc11.  In order to actually install the beta, though, I needed to first install 10 from the release DVD then reboot and do an upgrade install of f11.

So this is a rawhide issue, and at least it's a rawhide issue resulting from a clean upgrade from f10 to f11.
Comment 5 Matthias Clasen 2009-04-15 21:25:50 EDT
Ah, ok. I misunderstood the problem. Building tomboy with ppc now.

Note You need to log in before you can comment on or make changes to this bug.