Bug 495856 - snd-intel8x0m (note the 'm') should be blacklisted, it blocks intel audio cards from being used, make them look like modems
snd-intel8x0m (note the 'm') should be blacklisted, it blocks intel audio car...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 516998
  Show dependency treegraph
 
Reported: 2009-04-15 02:46 EDT by Diego Escalante Urrelo
Modified: 2010-02-17 22:53 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 22:53:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diego Escalante Urrelo 2009-04-15 02:46:09 EDT
Description of problem:
On a rawhide system, snd-intel8x0m is loaded besides snd-intel8x0; this causes a "modem" to be seen, pulseaudio confuses this like my card and refuses to start, hence leaving me w/o sound.

Version-Release number of selected component (if applicable):
module-init-tools-3.7-7.fc11.i586

How reproducible:
install f10, upgrade to rawhide

Steps to Reproduce:
1. boot
2. listen to standard 'beep' instead of nice sounds when events happen
3. put a sad face
  
Actual results:
The system beep is played instead of nice sounds

Expected results:
Nice sounds

Additional info:
I /suspect/ this could be kernel (I'm using .27 now, the latest one from F10) related BUT I don't think you should rule this out just because of that. Ubuntu blacklists intel8x0m by default, and I understand no big problem has arised.

Would you consider adding this to the default blacklist?
Comment 1 Bug Zapper 2009-06-09 09:50:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Karel Volný 2010-01-11 10:31:51 EST
please, could you test what is the behaviour on recent Fedora version?

if the bug persists, please add at least the information about your soundcard

(adding jkysela to CC, if he has something to say about the mentioned modules ...?)
Comment 4 Jaroslav Kysela 2010-01-20 05:24:36 EST
Please, append 'alsa-info.sh --no-upload' output to this bug when both modules are loaded in the system.

It appears like a PA problem. The both modules (snd-intel8x0 for audio and snd-intel8xm for modem) should co-exist together - the PCM devices are marked with SND_PCM_CLASS_MODEM .
Comment 5 Lennart Poettering 2010-02-15 19:15:30 EST
We actually do check if sound cards are modems and ignore them.

Diego, any chance you can check if the problem exists on F12?
Comment 6 Diego Escalante Urrelo 2010-02-17 01:14:01 EST
No, sorry I don't have a F12 at hand.

Let's just hope it's fixed now :-). On a side note, Debian recently removed that from its blacklist.conf... perhaps it's not causing troubles anymore? (haven't checked yet).
Comment 7 Lennart Poettering 2010-02-17 22:53:06 EST
We did some changes there recently in the F12 time frame, so this really should be fixed in Debian too if they have at least PA 0.9.19 or so.

Note You need to log in before you can comment on or make changes to this bug.