Bug 495895 - autofs5: large number of DNS lookups for hostnames associated with multiple ip addresses.
autofs5: large number of DNS lookups for hostnames associated with multiple i...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Ian Kent
BaseOS QE
:
Depends On: 495890
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 09:50 EDT by Ian Kent
Modified: 2010-10-23 05:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when autofs looked up a host name where when one NFS server name was associated with multiple IP adresses, autofs would repeat the query many times. As a consequence of these multiple queries, the mount would take a long time. Now, redundant queries have been removed, so that autofs performs the mount more quickly.
Story Points: ---
Clone Of: 495890
Environment:
Last Closed: 2009-09-02 08:00:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Kent 2009-04-15 09:50:36 EDT
+++ This bug was initially created as a clone of Bug #495890 +++

autofs5 produce massive number of DNS queries when one nfs server name is associated with many IP adresses. For example when one host has 40 IP adresses associated mounting one autofs directory produce ~160 DNS queries.

steps to reproduce :

1) Configure roundrobin DNS so that the autofs client resolve host1.example.com as below .

host host1.example.com
host1.example.com has address 10.65.6.193
host1.example.com has address 10.65.7.143
host1.example.com has address 10.65.7.225
host1.example.com has address 10.65.6.128

2) nfs server exports /tmp *(ro)

on autofs5 client , configure the map such as ,

/etc/auto.master :  
/misc   /etc/auto.misc

/etc/auto.misc   :  
test            host1.example.com:/tmp

Capture the network packets using tcpdump. 
On the client cd into /misc/test.
Check the number of DNS queries in the captured dump.

The table below lists the number of host lookups for varying number of ip addresses.
1 ip : 2 DNS lookup .
2 ip : 14 DNS lookups
3 ip : 20 DNS lookups
4 ip : 26 DNS lookups

The problem is also seen with autofs on RHEL 5.

Using the following patch fixes the problem.
http://ftp.kernel.org/pub/linux/daemons/autofs/v5/autofs-5.0.3-remove-redundant-dns-name-lookups.patch

--- Additional comment from ikent@redhat.com on 2009-04-15 09:48:02 EDT ---

(In reply to comment #0)
> The problem is also seen with autofs on RHEL 5.

That's true.

> 
> Using the following patch fixes the problem.
> http://ftp.kernel.org/pub/linux/daemons/autofs/v5/autofs-5.0.3-remove-redundant-dns-name-lookups.patch  

Right, this is one of the few (I think there are probably only two
things actually) that haven't been back ported to 5.0.1 in RHEL.
Sorry about this, I'll get onto it.
Comment 2 Ian Kent 2009-05-20 23:08:40 EDT
This issue has been fixed in the latest autofs package
autofs-5.0.1-0.rc2.125.

The autofs RHTS test bugzillas/bz495895 can be used to
verify this correction.
Comment 4 Ian Kent 2009-06-01 23:09:23 EDT
I'm afraid I must frop the manual umount recovery patch.
Internal regression testing has shown that it causes problems
with the autofs submount handling and after trying to fix it
for some time without success I have to concede defeat on
this, at least for now, as time has run out for RHEL-5.4.

At least this doesn't affect the fix for the root cause we
identified so, if you would like this further investigated,
please log a new bug and I'll revisit it for RHEL-5.5.

Sorry, for the inconvenience.
Comment 5 Chris Ward 2009-07-03 14:41:36 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 8 Ruediger Landmann 2009-08-31 18:21:29 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Previously, when autofs looked up a host name where when one NFS server name was associated with multiple IP adresses, autofs would repeat the query many times. As a consequence of these multiple queries, the mount would take a long time. Now, redundant queries have been removed, so that autofs performs the mount more quickly.
Comment 9 errata-xmlrpc 2009-09-02 08:00:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1397.html

Note You need to log in before you can comment on or make changes to this bug.