Bug 495910 - all further tabs open in / if first tab has sudo command running
all further tabs open in / if first tab has sudo command running
Status: CLOSED DUPLICATE of bug 496947
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 10:37 EDT by Maxim Burgerhout
Modified: 2009-05-27 17:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 17:05:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Burgerhout 2009-04-15 10:37:56 EDT
Description of problem:
If a program is running with sudo in the first and only tab of gnome terminal, all further shells (in second tab and up) are spawned with / as the working directory.

Version-Release number of selected component (if applicable):
2.26.1-1.f11

How reproducible:
Always

Steps to Reproduce:
1. open gnome-terminal
2. run program in gnome-terminal's first tab with sudo (say 'sudo visudo')
3. open second tab while 'sudo visudo' is still running
4. see that shells in tabs after the first one open in / instead of in the working directory of the first tab
  
Actual results:
shells in second and further tabs open with / as the working directory

Expected results:
second and further to spawn shells in working directory of the ordinary user in the first shell

Additional info:
Comment 1 Will Woods 2009-05-27 17:05:43 EDT

*** This bug has been marked as a duplicate of bug 496947 ***

Note You need to log in before you can comment on or make changes to this bug.