Bug 495919 - login using fingerprint auth not working
login using fingerprint auth not working
Status: CLOSED DUPLICATE of bug 481273
Product: Fedora
Classification: Fedora
Component: fprintd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 11:08 EDT by Dave Maley
Modified: 2009-04-16 12:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 11:43:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal output (1.61 KB, text/plain)
2009-04-15 11:13 EDT, Dave Maley
no flags Details

  None (edit)
Description Dave Maley 2009-04-15 11:08:08 EDT
Description of problem:
I've enabled fingerprint reader in authconfig and enabled fingerprint login via gnome-about-me however I'm unable to login using a fingerprint swipe.


Version-Release number of selected component (if applicable):
fprintd-0.1-8.git04fd09cfa.fc11.x86_64


How reproducible:
every time


Steps to Reproduce:
1. select user from gdm login screen
2. swipe finger on reader
3.
  

Actual results:
nothing happens, no login, no error, nothing appears to get logged


Expected results:
login


Additional info:
This is on a Lenovo T61 (I'll attach relevant lshal output) w/ all updates applied 2008-04-15
Comment 1 Dave Maley 2009-04-15 11:13:56 EDT
Created attachment 339697 [details]
lshal output
Comment 2 Bastien Nocera 2009-04-15 13:12:14 EDT
lshal output doesn't help me.

Please enable debug (adding the "debug" keyword to the pam_fprintd line) in the PAM config, and send me the relevant lines in the /var/log/secure when the problem happens (or fails to happen I guess).
Comment 3 Dave Maley 2009-04-16 02:03:37 EDT
I've added "debug" to the pam_fprintd.so lines in both:

/etc/pam.d/system-auth
/etc/pam.d/fingerprint-auth

..but I'm still getting nothing in /var/log/secure for the failed attempts.  I'll keep poking at this tomorrow to see if I can get the debugging output, but if you have suggestions/pointers pls do let me know.
Comment 4 Bastien Nocera 2009-04-16 11:07:28 EDT
I forgot to ask, did you even get asked to swipe your finger, or did you get the password text entry? If you didn't get asked, then it wasn't enabled.

You also need gdm-plugin-fingerprint install (see also bug 481273)
Comment 5 Dave Maley 2009-04-16 11:43:42 EDT
d'oh!  Yep that was it.  Since gnome-about-me detected my fprint swipes and concluded w/ a statement that I should be able to login now using fprint I ass-umed my system was all set and ready to go.  Sad thing is I actually did see bug 481273 before filing this, but didn't notice the mention of gdm-plugin-fingerprint ....

Thanks for the assist!

*** This bug has been marked as a duplicate of bug 481273 ***
Comment 6 Bastien Nocera 2009-04-16 12:01:05 EDT
I've changed about-me to not show enrollment if the gdm plugin isn't available.

Note You need to log in before you can comment on or make changes to this bug.