This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 495941 - pam_succeed_if should match against supplied username, not what some NSS module made out of it
pam_succeed_if should match against supplied username, not what some NSS modu...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 12:07 EDT by Nils Philippsen
Modified: 2009-09-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: pam-1.1.0-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-01 11:37:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2009-04-15 12:07:11 EDT
Description of problem:
When attempting to prohibit e.g. logins with a supplied uppercase user name, this won't work with users coming out of ADS because winbindd (via nss_winbind) converts the supplied user name to lower case.

Version-Release number of selected component (if applicable):
pam-1.0.2-2.fc10

How reproducible:
Reproducible

Steps to Reproduce:
1. have a user in ADS, integrated via winbind
2. auth sufficient user !~ [*[A-Z\]*]
3. Try to login via ssh, supplying at least one capital character in the user name
  
Actual results:
Logging in works, "user ... met requirement" in the log

Expected results:
Logging in doesn't work

Additional info:

Note You need to log in before you can comment on or make changes to this bug.