Bug 495961 - Out of memory error when adding errata
Out of memory error when adding errata
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
520
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Sayli Karmarkar
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-04-15 14:02 EDT by Stanislav Polasek
Modified: 2009-09-10 16:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:35:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
relevant part of the catalina.out (7.34 KB, application/octet-stream)
2009-04-15 14:02 EDT, Stanislav Polasek
no flags Details
The menu for add errata action (92.94 KB, image/png)
2009-04-18 04:05 EDT, Stanislav Polasek
no flags Details
Overview of selected errata (77.54 KB, image/png)
2009-04-18 04:06 EDT, Stanislav Polasek
no flags Details
Result of the add errata action: Internal server error (57.03 KB, image/png)
2009-04-18 04:07 EDT, Stanislav Polasek
no flags Details

  None (edit)
Description Stanislav Polasek 2009-04-15 14:02:34 EDT
Created attachment 339729 [details]
relevant part of the catalina.out

Description of problem:
Adding errata (all rhel 5 64bit) to cloned channel using web GUI ends with "Internal Server Error" web page. Tomcat/catalina reports Out of memory error.

Version-Release number of selected component (if applicable):
5.2

How reproducible:
Always

Steps to Reproduce:
1. create cloned channel with no errata
2. add all available errata (currently we have 844 rhel5 erratas)
3. action ends with out of memory error
  
Actual results:
Internal Server Error web page

Expected results:
Errata added to the cloned channel

Additional info:
System is HP Proliant with 8G of RAM
RHEL 4 x86_64 U7
I verified the same problem exists even in xen virtual machine with the same OS and with 2G-4G of mem.

See attached catallina message log
Comment 1 Clifford Perry 2009-04-17 10:31:40 EDT
Hi there, 
I do not have a RHEL 5 x86_64 + Sat 5.2 system at hand to attempt to replicate. 

Using a RHEL 4 x86_64 + Sat 5.2 system with 4 gig RAM - I had a RHEL 5 channel cloned, with no cloned errata. I then went to the Channel > Errata > Clone (network/software/channels/manage/errata/clone.pxt) and successfully cloned almost 1000 errata to the channel. 

967 errata cloned into Clone of Red Hat Enterprise Linux (v. 5 for 64-bit x86_64).
3 errata published to Clone of Red Hat Enterprise Linux (v. 5 for 64-bit x86_64).

This code path is functional, so I am going to ask that you please open a support ticket for this. We can then review/investigate further to determine why it is failing for yourself. Once our support team has assisted in tracking down this to a specific issue, we can determine if code changes are needed. 

Thanks,
Cliff.
Comment 2 Stanislav Polasek 2009-04-18 04:05:29 EDT
Created attachment 340133 [details]
The menu for add errata action
Comment 3 Stanislav Polasek 2009-04-18 04:06:40 EDT
Created attachment 340134 [details]
Overview of selected errata
Comment 4 Stanislav Polasek 2009-04-18 04:07:50 EDT
Created attachment 340135 [details]
Result of the add errata action: Internal server error
Comment 5 Stanislav Polasek 2009-04-18 04:14:17 EDT
Hi. We use RHEL 4.7 x86_64, too. The only difference I am able to see is we use the "Add Errata" way, not the "Clone Errata". As I understood, the "Clone errata" is going to be deprecated, isn't it?

I added some screenshots to describe the proces. We will file the service ticket on Monday.

Thank you.

st.
Comment 7 Clifford Perry 2009-04-21 14:19:12 EDT
Hi - thank you for the screen shots. I was able to replicate myself as well - Java out of memory errors, after waiting 2+ hours for it to complete. I am going to align this for further developer review as part of the 5.3 Satellite development cycles. 

Cliff
Comment 8 Justin Sherrill 2009-04-24 16:22:23 EDT
So i wasn't able to reproduce the Out of memory error, but this may be due to some changes that were made previously for satellite 5.3 that made the errata process asynchronous.

I did notice that in several situations though, some of the pages would time out because they would take too long to load.   So i improved the queries greatly, which should reduce page load time. 

Another thing it was doing was not re-using cloned errata if one existed for a particular errata.  Now i re-use them.  This brought the time down to be similar to the old perl page for clone errata.

ba17663
Comment 9 Justin Sherrill 2009-04-24 16:31:21 EDT
QA might be able to reproduce the out of memory errors (if they still exist).

QA person:

To try to reproduce, 

1.  clone a channel to it's original state
2.  Go to channels -> manage channels -> click on that clone -> errata -> add -> add red hat errata -> select all -> confirm -> clone
3.  Within a few seconds the page should come back.  monitor /var/log/tomcat5/catalina.out for the next 10-15 minutes and make sure no tracebacks are thrown.

Thanks,
Comment 10 Sayli Karmarkar 2009-06-02 20:18:18 EDT
Verified. Errata clones without any traceback in /var/log/tomcat5/catalina.out.
Comment 11 Miroslav Suchý 2009-08-24 10:25:05 EDT
verified in stage on xen5.
I went according to #9 and got:
Succesfully added 3322 package(s) and scheduled 936 errata to be cloned to channel ... 
No errors in catalina.out
Comment 12 Brandon Perkins 2009-09-10 16:35:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.