Bug 495992 - form letters "please send logs" omit important case
form letters "please send logs" omit important case
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 17:00 EDT by John Reiser
Modified: 2009-04-20 09:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 04:47:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-04-15 17:00:48 EDT
Description of problem: The form letters which ask a bug reporter to attach logs, such as https://bugzilla.redhat.com/show_bug.cgi?id=494390#c1 (/tmp/X*) or https://bugzilla.redhat.com/show_bug.cgi?id=494390#c7 (/var/log/Xorg.*.log), forget that there is another location: /var/log/anaconda.xlog.  This location is somewhat unknown and is easy to overlook (it isn't named Xorg*.log), but it may be the only place where a log is available.  This is particularly true for some problems during a Fedora install that is being performed by anaconda.


Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.6.1-1.fc11

How reproducible: always


Steps to Reproduce:
1. file a bug report relating to x11 xserver or xdriver, but do not attach the xserver log
2.
3.
  
Actual results:  Request to send xserver log does not mention that [/mnt/sysimage]/var/log/anaconda.xlog is one place to check.


Expected results: Request to send xserver log mentions all places where such a log may exist.


Additional info:
Comment 1 Matěj Cepl 2009-04-20 04:47:11 EDT
Of course I know about /var/log/anaconda.xlog. Except that its usage is kind of limited. Most of the time there is SOMETHING in /tmp (for installation) or in /var/log/Xorg*. Exceptional cases when it is not so, could be dealt separately, but I don't want to burden reporters with asking them for unnecessary logs. So on further consideration, I gave up and ask for /var/log/anaconda.xlog for LiveCD/installation-broken cases:

Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

When the anaconda crashes, please, switch to the console (Ctrl+Alt+F2) and copy /tmp/X* and /var/log/anaconda.xlog to some other place -- USB stick, some other computer via network, some on the Internet, and please attach it to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

-----------------

However, I won't give in for normal (/var/log/Xorg.0.log) message.
Comment 2 John Reiser 2009-04-20 09:33:46 EDT
It would have helped me [and therefore, you] to mention the alternate path /var/log/anaconda.xlog in the requests for info on bug 494390.  Because of the many large changes in kernel modesetting and the "big 3" X11 chip drivers (intel, ati, nouveau), it seems likely that general release of Fedora 11 may encounter more instances of problems similar to the ones I have seen during installs of beta software, where the usual paths are not accessible but the alternate path is.  The revised form letter in Comment #1 above helps in this case.

Note You need to log in before you can comment on or make changes to this bug.