Bug 496000 - Installed libgweather package is huge : 80MB in size
Installed libgweather package is huge : 80MB in size
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgweather (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 17:53 EDT by Matthias Saou
Modified: 2013-01-06 13:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 11:54:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2009-04-15 17:53:58 EDT
The hack to avoid useless translations in the current package decreases the size already for sure, but on my F-10 laptop, I've just realized that libgweather is the 5th biggest package I have installed :

[...]
75114674	kernel
81167491	libgweather
83453727	java-1.6.0-openjdk
93175744	glibc-common
112425640	texlive-texmf-fonts

It takes up even more disk space than a kernel! The original sources are 7MB and the binary rpm is 14MB.

That size is because of the uncompressed XML "Locations" files, which take up ~1MB for each locale. I see various solutions, though I don't know the complexity of each :
 * Have those files be compressed on disk, uncompressed at runtime
 * Include a fix or hack similar to the translations one to avoid duplicates
 * Use the translation files if the end content is the same (though I doubt it)

FYI, I just tried to see if I could just remove the package (since I don't use ant weather programs at all)... but it would remove gnome-panel (because of gnome-applets), so "avoiding" the issue isn't an easy option ;-)
Comment 1 Bug Zapper 2009-06-09 09:53:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Matthias Saou 2009-09-14 11:14:17 EDT
Moving back to devel, as things are still the same in Rawhide. I don't think there is any easy solution to this, but who knows. Just making sure that removing libgweather only removes the weather applet and not the entire GNOME panel would probably be a good start. Maybe even all of the applets, since apparently the panel directly depends on libgweather for some reason (doesn't seem obvious to me) :

$ sudo yum remove libgweather
Loaded plugins: dellsysidplugin, refresh-packagekit
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package libgweather.x86_64 0:2.24.2-1.fc10 set to be erased
--> Processing Dependency: libgweather.so.1()(64bit) for package: 1:gnome-applets-2.24.3.1-1.fc10.x86_64
--> Processing Dependency: libgweather.so.1()(64bit) for package: gnome-panel-2.24.3-2.fc10.x86_64
--> Running transaction check
---> Package gnome-applets.x86_64 1:2.24.3.1-1.fc10 set to be erased
---> Package gnome-panel.x86_64 0:2.24.3-2.fc10 set to be erased
Comment 3 Matthias Clasen 2009-09-14 11:20:45 EDT
What makes you think that things are the same ?

rpm -q --qf "%{SIZE}\n" libgweather
18113075
Comment 4 Matthias Saou 2009-09-14 11:32:27 EDT
Oops, I was checking on a Fedora 10 system instead of Rawhide, sorry.

If this is now fixed, this is great news, thanks a lot!

(I'll let you close this ticket if such is the case)
Comment 5 Matthias Clasen 2009-09-14 11:54:23 EDT
yes, fixed in soon-to-be F12
Comment 6 Valent Turkovic 2013-01-06 13:56:14 EST
Fedora 18 package is even bigger, over 90MB.
Comment 7 Valent Turkovic 2013-01-06 13:58:11 EST
How to reopen this bug?

Note You need to log in before you can comment on or make changes to this bug.