Bug 496018 - message bus timeout when installing an application takes too long (when triggered from nautilus missing mime handler)
message bus timeout when installing an application takes too long (when trigg...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 21:30 EDT by Diego Escalante Urrelo
Modified: 2010-03-23 06:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 06:26:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diego Escalante Urrelo 2009-04-15 21:30:30 EDT
Description of problem:
I had this .ppt file and when double clicked I realized I had no openoffice, so I followed the hint to search for an application.
Obviously, being openoffice, it took ages to download and install. Somewhere during the process I saw an ugly warning dialog saying that the operation failed because the message bus timed out (although the installation kept going, the original "search" died).

Version-Release number of selected component (if applicable):
PackageKit-yum-plugin-0.4.6-2.fc11.i586
PackageKit-glib-0.4.6-2.fc11.i586
PackageKit-gstreamer-plugin-0.4.6-2.fc11.i586
gnome-packagekit-2.27.1-1.fc11.i586
PackageKit-gtk-module-0.4.6-2.fc11.i586
PackageKit-0.4.6-2.fc11.i586
PackageKit-yum-0.4.6-2.fc11.i586

How reproducible:
Once, but I suspect always.

Steps to Reproduce:
1. Double click a file in nautilus that has no handler, in my case a ppt when I had no openoffice installed
2. Search for a handler, accept to install it.
3. Wait until somewhere after a long time, the original "search" notifies you that it failed because of a message bus timeout, but the installation keeps going and ends succesfully.
  
Actual results:
A scary message bus timeout -operation failed- message

Expected results:
No scary message

+ Info:
After ooo-impress was installed, the file did not launch, I suspect this is because the "original operation" (the search) died, so the install was completed but no one was watching it to do something after it.
Comment 1 Richard Hughes 2009-06-03 05:26:14 EDT
Hmm, I suspect this will be fixed with the recent timeout fixes in DBus. I'll take a look.
Comment 2 Bug Zapper 2009-06-09 09:53:47 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.