Bug 496026 - Fails to suspend on 855GM, when using KMS; apparently latest fix is broken, PM_FUNCTIONS' add_parameter function missing
Fails to suspend on 855GM, when using KMS; apparently latest fix is broken, P...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 01:39 EDT by Diego Escalante Urrelo
Modified: 2015-03-04 20:20 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-24 04:45:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diego Escalante Urrelo 2009-04-16 01:39:01 EDT
pm-suspend.log:
Initial commandline parameters: 
Thu Apr 16 00:29:55 PET 2009: Running hooks for suspend.
/usr/lib/pm-utils/sleep.d/00auto-quirk suspend suspend: Adding quirks from HAL: --quirk-dpms-on --quirk-save-pci 
success.
/usr/lib/pm-utils/sleep.d/00logging suspend suspend: Linux milkyway.rainyumbrella.org 2.6.29.1-70.fc11.i586 #1 SMP Mon Apr 13 14:00:43 EDT 2009 i686 i686 i386 GNU/Linux
Module                  Size  Used by
fuse                   49800  0 
sco                     9396  2 
bridge                 41540  0 
stp                     1948  1 bridge
llc                     4788  2 bridge,stp
bnep                   10920  2 
l2cap                  18936  3 bnep
bluetooth              44760  5 sco,bnep,l2cap
vboxnetflt             71848  0 
vboxdrv                96632  1 vboxnetflt
vfat                    8620  0 
fat                    41024  1 vfat
ip6t_REJECT             3160  2 
nf_conntrack_ipv6      11376  2 
ip6table_filter         3136  1 
ip6_tables             10708  1 ip6table_filter
ipv6                  233636  12 ip6t_REJECT,nf_conntrack_ipv6
cpufreq_ondemand        6056  1 
acpi_cpufreq            8040  0 
dm_multipath           13524  0 
uinput                  6540  0 
ndiswrapper           155532  0 
snd_intel8x0           27440  3 
snd_ac97_codec         91772  1 snd_intel8x0
ac97_bus                1400  1 snd_ac97_codec
snd_pcm                62556  3 snd_intel8x0,snd_ac97_codec
snd_timer              17900  1 snd_pcm
iTCO_wdt               10448  0 
snd                    49044  9 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
iTCO_vendor_support     2736  1 iTCO_wdt
soundcore               5404  1 snd
thinkpad_acpi          53924  0 
usb_storage            82480  0 
yenta_socket           21240  2 
ppdev                   6344  0 
rfkill                  8816  1 thinkpad_acpi
hwmon                   2148  1 thinkpad_acpi
snd_page_alloc          7572  2 snd_intel8x0,snd_pcm
rsrc_nonstatic          9428  1 yenta_socket
i2c_i801                8056  0 
parport_pc             22088  0 
pcspkr                  2156  0 
parport                28520  2 ppdev,parport_pc
ata_generic             4264  0 
pata_acpi               3624  0 
i915                  140200  2 
drm                   165500  2 i915
i2c_algo_bit            4788  1 i915
i2c_core               18016  4 i2c_i801,i915,drm,i2c_algo_bit
video                  17328  1 i915
output                  2324  1 video
             total       used       free     shared    buffers     cached
Mem:       1277744     605136     672608          0      26464     397032
-/+ buffers/cache:     181640    1096104
Swap:       682720          0     682720
success.
/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
/usr/lib/pm-utils/sleep.d/01grub suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: success.
/usr/lib/pm-utils/sleep.d/56atd suspend suspend: success.
/usr/lib/pm-utils/sleep.d/75modules suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/90clock suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
/usr/lib/pm-utils/sleep.d/95led suspend suspend: success.
/usr/lib/pm-utils/sleep.d/95packagekit suspend suspend: success.

vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv

/usr/lib/pm-utils/sleep.d/98smart-kernel-video suspend suspend: /usr/lib/pm-utils/sleep.d/98smart-kernel-video: line 37: add_parameter: command not found

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

success.
/usr/lib/pm-utils/sleep.d/99hd-apm-restore.hook suspend suspend:  HDIO_DRIVE_CMD(identify) failed: Invalid exchange
Advanced Power Management not supported by device sdb.
saving level 128 for device sda
success.
/usr/lib/pm-utils/sleep.d/99video suspend suspend: kernel.acpi_video_flags = 0
success.
Thu Apr 16 00:29:56 PET 2009: performing suspend
Comment 1 francois rigaut 2009-04-23 23:29:54 EDT
I had the same problem.

turns out add_parameter is a typo. should be add_parameters (with an S).

fixing the typo also fixed the suspend problem for me (at least I went flawlessly thru 6 suspend/resume cycle).

I hope the devs read this.
Comment 2 francois rigaut 2009-04-24 00:22:49 EDT
well apparently it's known and fixed in pm-utils git 

http://cgit.freedesktop.org/pm-utils/commit/?id=e5cdb5bb6a573a36b0c872c889c8b8f25009cc45

now it'll have to make it to rawhide.
Comment 3 Richard Hughes 2009-04-24 05:48:45 EDT
Building as: http://koji.fedoraproject.org/koji/taskinfo?taskID=1318694

I'll request tags now.
Comment 4 Richard Hughes 2009-04-24 05:52:46 EDT
Request here: https://fedorahosted.org/rel-eng/ticket/1627
Comment 5 Bug Zapper 2009-06-09 09:54:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Nigel Jones 2009-09-10 02:31:45 EDT
Observed same problem on F12/rawhide with Thinkpad T60p. M52/V500 gfx and KMS enabled.

The result was a failure to suspend, as well as just the log entry. Fixing up the script with the missing s allowed suspend to work fine.

Current version on F12 is pm-utils-1.2.5-6.fc12.i686
Comment 7 Jiri Skala 2010-02-24 04:45:39 EST
I suppose the bug is fixed so I'm going to close it. If the problem survive reopen this bug.

There is another bug against F-12 #538434.

Note You need to log in before you can comment on or make changes to this bug.