Bug 496038 - PATCH: fix drive order in isw raid01 setups to match BIOS driver order
PATCH: fix drive order in isw raid01 setups to match BIOS driver order
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dmraid (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Heinz Mauelshagen
Cluster QE
:
Depends On:
Blocks: 475386
  Show dependency treegraph
 
Reported: 2009-04-16 04:36 EDT by Hans de Goede
Modified: 2009-09-02 07:17 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:17:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH: fix drive order in isw raid01 setups to match BIOS driver order (414 bytes, patch)
2009-04-16 04:36 EDT, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2009-04-16 04:36:30 EDT
Created attachment 339812 [details]
PATCH: fix drive order in isw raid01 setups to match BIOS driver order

Description of problem:
This patch fixes a mismatch between BIOS and dmraid's view of ISW raid 01 sets,
so that after we've written data to it, the BIOS can actually read the data
sanely. This fixes booting from ISW raid 10 sets.

This patch is quite trivial and has been extensively tested in Fedora.
Comment 2 Denise Dumas 2009-04-16 08:31:32 EDT
Note that this is not additional work for QA, because verifying 475386 (including successful boot after install) also verifies this patch.
Comment 7 errata-xmlrpc 2009-09-02 07:17:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1347.html

Note You need to log in before you can comment on or make changes to this bug.