Bug 49607 - Man page for cal command (/usr/bin/cal) is incorrect
Man page for cal command (/usr/bin/cal) is incorrect
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-21 11:15 EDT by Wayne Pollock
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-21 11:16:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Pollock 2001-07-21 11:15:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win98; U)

Description of problem:
The man page synopsis for cal shows (and has since 6.1 at least) as:
cal [-mjy] [month [year]]
This is incorrect, it should be:
cal [-mjy] [[month] year]


How reproducible:
Always

Steps to Reproduce:
1.man cal
2.cal 2000
3.cal 12
	
The man page reports that cal can be run with a month alone, or month and year as arguments.  Cal
actually allows a year alone, or month and year.  This can be seen by running the commands above.

Actual Results:  Got bad man page.

Expected Results:  Get good man page.

Additional info:
Comment 1 Elliot Lee 2001-07-23 18:44:14 EDT
Already appears to be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.